ICINGA For Windows - Error Installing Agent : [Error]: Failed to fetch host/template configuration from Icinga Director Self-Service API

I’m trying to installa IfW Agent usin3 Option 3 for connection to ICINGA2 Master

[Error]: Failed to fetch host/template configuration from Icinga Director Self-Service API because of SSL/TLS error. Please ensure the certificate is valid and use “Enable-IcingaUntrustedCertificateValidation” for self-signed certificates or install the certificate on this machine.

The ICINGA2 Master Note Do not HAVE a Valid SSL certificate (it is a demo system)… this can be the problem ?
Can I bypass this error ?

My Enviroment
Environment configuration:

PowerShell Root => C:\Program Files\WindowsPowerShell\Modules
Icinga for Windows Service Path => C:\Program Files\icinga-framework-service
Icinga for Windows Service User => NT Authority\NetworkService
Icinga for Windows Service Pid => 4672
Icinga for Windows JEA Pid =>
Icinga Agent Path =>
Icinga Agent User => NT AUTHORITY\NetworkService
Defined Default User => NT Authority\NetworkService
Icinga Managed User => False
PowerShell Version => 5.1.19041.3031
Operating System => Microsoft Windows 10 Pro
Operating System Version => 10.0.19045
JEA Context =>
JEA Session File =>
Api Check Forwarder => True
Debug Mode => False

Component Version Available

framework 1.11.0 1.11.0
plugins 1.11.0 1.11.0
service 1.2.0 1.2.0
----- ICINGA -Master node -----
|Icinga Web 2 Version|2.11.4|
|PHP Version|7.4.3-4ubuntu2.19|
director 1.10.1

yes, run Enable-IcingaUntrustedCertificateValidation before doing any install via powershell.

post your powershell config file, or the method you use to install an agent that will be easier to push you into the right direction

Also what type of certificate are you using?

I Have already try to run first “Enable-IcingaUntrustedCertificateValidation” and after start the Installation (in the same PowerShell Session) - But the results was the same.

Where I can find the “powershell config file” ?

you write it yourself.
how did you start installation procedure?

Icinga -manage
And follow the screen…

you need to Enable-IcingaUntrustedCertificateValidation with the menu items
Settings-> Troubleshooting-> Allow untrusted certificate communication (This session)

I tested olso in this way.
Same results