Icinga Director tab not appear in Icinga Web console

Here we follow KB: Installation - Icinga Director to deploy “Icinga Director” in Icinga Web console, but when try “icingacli module enable director”, it reports: “Launching the run script /etc/icingaweb2/enabledModules/director/run.php for module director failed with the following exception: Missing dependencies, please check”. And in Icinga Web 2 frontend, from Configuration / Modules can see “Icinga Director”, but version info is empty. And from the frontend TAB, I can’t see “Icinga Director” exist. So I think somewhere configuration error. Anyone can support me? Thanks.

  • Director version (System - About):1.8.1
  • Icinga Web 2 version and modules (System - About): 2.8.4
  • Icinga 2 version (icinga2 --version): v2.13.0-11-ga47575549
  • Operating System and version: SuSE 15 sp3
  • Webserver, PHP versions: php7-7.4.6-3.22.1.x86_64 & apache2-2.4.43-3.22.1.x86_64

I suppose my issue is related to below modules not installed and enabled. And my question is how to install and enable below modules in Icinga Web 2.

  • The following Icinga modules must be installed and enabled:
  • ipl (>=0.3.0)
  • incubator (>=0.5.0)
  • reactbundle (>=0.7.0)


first of all did you checked the linked modules? Because two auf them are deprecated now (written in big letters in the description) :wink:
And about your question for installing: There is also written an installation instruction. Did you still tried them? Any problems/error messages etc.?

1 Like

@Huang in response to this, ipl and reactbundle are now part of GitHub - Icinga/icinga-php-library: Bundle for all Icinga PHP libraries

With that said, I didn’t know this last week and was still able to grab the versions from their respective (DEPRECATED) repos. Their repos have easy to follow steps if you’re comfortable with BASH.

However I’m with @stevie-sy on this – use the new package that has them.

I personally prefer the git installation method in their README.md, as it makes updates pretty simple by doing a git fetch and a git checkout stable/new.version.number

Hello, I tried based on the installation link: Installation - Icinga Director. Yes for “ill/incubator/reactbundle” looks support lower version Icinga web2 and director. And I use latest version currently and seems they are deprecated. But for safe, I still using git clone to rsync to local icinga:/usr/share/icingaweb2/modules. And when type “icingacli module list” and I can see related modules are all enabled and with version info. But from Icinga Web2 front console, I still see director module shows version info as “empty” and can’t enable. Of course, the director TAB doesn’t appear in web console. Do u know the root cause?

director 1.8.1 enabled Director - Config tool for Icinga 2
doc 2.8.4 enabled Documentation module
incubator 0.6.0 enabled Incubator provides bleeding-edge libraries
ipl v0.5.0 enabled The Icinga PHP library
monitoring 2.8.4 enabled Icinga monitoring module
reactbundle 0.9.0 enabled ReactPHP-based 3rd party libraries
setup 2.8.4 enabled Setup module
translation 2.8.4 enabled Translation module


ok it looks like the documentary hasn’t been adapted yet.

To update the modules you’ll need to use git pull for new installation git clone. And after use git checkout to use the specific version according to the documentation. Just to mention it and to be sure.

I have no idea why the version field from the directory is empty. But we still doesn’t updates to 1.8.1 and also the icingaweb to the new version. But you could check the file module.info in the module folder

I opened a PR in the director to adapt the documentation.
If you notice something about the documentation not being up-to-date you can always open a pull request yourself! Check out the guide I wrote on the topic and / or the CONTRIBUTING.md in the respective repositories for more help on how to get started.

1 Like

hello, do you have KB about how to configure iCINGA Director about my issue I met? The official document is really too simple and not suitable. Thx.


Can you please show the output of the following commands while being inside the /usr/share/icingaweb2/modules/director folder:

  • git status
  • ls -la

seems to me there is something wrong with it and therefore the module is not correctly recognized

What says git branch -a? Here you see what Branches exists on your server. That one, which is activated, is marked with *.

I’m a new learner of Git and Icinga. And almost follow the standard documents to implement Icinga Director. Please see my output as you asked. Thanks.

No worries about being new and learning :slight_smile:
Your second picture shows the same output as before (with git status und ls -la) :wink:

I’m a bit confused as to why there is now branch checked out.
Please do a git checkout v1.8.1 and check if that changes anything in the webinterface.

If not I would completely remove the director folder and re-do the whole module installation (like done in the install instructions)

rm -rf /usr/share/icingaweb2/modules/director


useradd -r -g icingaweb2 -d /var/lib/icingadirector -s /bin/false icingadirector
install -d -o icingadirector -g icingaweb2 -m 0750 /var/lib/icingadirector
git clone "${REPO_URL}" "${TARGET_DIR}" --branch v${MODULE_VERSION}
cp "${TARGET_DIR}/contrib/systemd/icinga-director.service" /etc/systemd/system/

icingacli module enable director
systemctl daemon-reload
systemctl enable icinga-director.service
systemctl start icinga-director.service

Your permissions does not allow access for anybody else than root.

1 Like

Hello, looks some steps in your guideline doesn’t appear in KB: https://icinga.com/docs/icinga-director/latest/doc/02-Installation/.

Here I follow your steps and looks only last step has issue. Can you guide based on it?

What is the status now?
Is the director module correctly displayed in the webinterface?
Check the output of

  • git status (should now be v1.8.1)
  • ls -la (check if permissions allow other users access)
  • systemctl status icinga-director

I follow your steps and combine with Icinga Director official installation document, still looks Director module in front console of Icinga Web2 as version info empty. Tried several times from my VM snapshot. All same result. It looks the last step “systemctl start Icinga-director.service” has issue during startup.

what do u mean about so call ed permissions.

icinga:/usr/share/icingaweb2/modules # cat /etc/passwd
chrony:x:476:476:Chrony Daemon:/var/lib/chrony:/bin/false
lp:x:498:489:Printing daemon:/var/spool/lpd:/sbin/nologin
mail:x:499:499:Mailer daemon:/var/spool/clientmqueue:/sbin/nologin
man:x:13:62:Manual pages viewer:/var/lib/empty:/sbin/nologin
messagebus:x:497:484:User for D-Bus:/run/dbus:/sbin/nologin
nscd:x:474:475:User for nscd:/run/nscd:/sbin/nologin
polkitd:x:495:482:User for polkitd:/var/lib/polkit:/sbin/nologin
postfix:x:51:51:Postfix Daemon:/var/spool/postfix:/bin/false
rpc:x:475:65534:user for rpcbind:/var/lib/empty:/sbin/nologin
sshd:x:496:483:SSH daemon:/var/lib/sshd:/bin/false
statd:x:473:65533:NFS statd daemon:/var/lib/nfs:/sbin/nologin
systemd-coredump:x:477:477:systemd Core Dumper:/:/sbin/nologin
systemd-network:x:480:480:systemd Network Management:/:/sbin/nologin
systemd-resolve:x:479:479:systemd Resolver:/:/sbin/nologin
systemd-timesync:x:478:478:systemd Time Synchronization:/:/sbin/nologin
cn1hh006:x:1000:100:Admin Service Account:/home/cn1hh006:/bin/bash
mysql:x:60:60:MySQL database admin:/var/lib/mysql:/sbin/nologin
wwwrun:x:471:471:WWW daemon apache:/var/lib/wwwrun:/sbin/nologin
svn:x:470:470:user for Apache Subversion svnserve:/srv/svn:/sbin/nologin

Ok. So still not working correctly.
What is strange to me is that your /usr/share/icingaweb2/modules is a git repo, not sure if that can be an issue.

About the permissions: The ls -la output you posted of the director folder showed that the files and the folder is only accessible by root
My ls -la output for comparison:

root@server:/usr/share/icingaweb2/modules/director# ls -la
total 120
drwxr-xr-x 11 root root  4096 Aug 13 06:37 .
drwxr-xr-x 14 root root  4096 Jun  9 12:15 ..
drwxr-xr-x  8 root root  4096 Aug 13 06:37 .git
drwxr-xr-x  3 root root  4096 Jun 15 06:31 .github
-rw-r--r--  1 root root    63 Feb 15 14:00 .gitignore
-rw-r--r--  1 root root  4060 Feb 15 14:00 .gitlab-ci.yml
-rw-r--r--  1 root root   930 Jun 15 06:31 .travis.yml
-rw-r--r--  1 root root 18092 Feb 15 14:00 LICENSE
-rw-r--r--  1 root root  3142 Feb 15 14:00 README.md
drwxr-xr-x  7 root root  4096 Feb 15 14:00 application
-rw-r--r--  1 root root  5286 Jun 15 06:31 configuration.php
drwxr-xr-x  5 root root  4096 Feb 15 14:00 contrib
drwxr-xr-x  3 root root  4096 Aug 13 06:37 doc
drwxr-xr-x  3 root root  4096 Jun 15 06:31 library
-rw-r--r--  1 root root   274 Aug 13 06:37 module.info
-rw-r--r--  1 root root   556 Jun 15 06:31 phpcs.xml
-rw-r--r--  1 root root   578 Feb 15 14:00 phpunit.xml
drwxr-xr-x  5 root root  4096 Feb 15 14:00 public
-rw-r--r--  1 root root  6364 Jun 15 06:31 register-hooks.php
-rw-r--r--  1 root root   548 Feb 15 14:00 run-missingdeps.php
-rw-r--r--  1 root root   660 Feb 15 14:00 run-php5.3.php
-rw-r--r--  1 root root   431 Aug 13 06:37 run.php
drwxr-xr-x  6 root root  4096 Jun 15 06:31 schema
drwxr-xr-x  4 root root  4096 Jun 15 06:31 test

The service not starting might be related to the permission, so check those.
But the service not starting does not interfere with the module being displayed. It is “just” for executing import&sync jobs automatically.