Icinga Director depends on the following modules, please install/upgrade as required


How to enable [incubator], i can see in github there is v0.3 but we need 0.5 how to do it?


I can see v0.5.0 as latest version on github :wink:

if you think your repo is up to date on your server try this command to see what branches are included:

git branch -a

if you want to install this, try these steps:

if not already installed:

cd /usr/share/icingaweb2/modules
git clone https://github.com/Icinga/icingaweb2-module-incubator.git incubator

if already installed, get new newest version:

cd /usr/share/icingaweb2/modules
git pull   

after checkout the version you like (e.g. v0.5.0):

git checkout v0.5.0

after actiate the module in icingaweb:

or activate the module with the CLI:
icingacli module enable incubator

1 Like

This will checkout the tag as detached head which makes it hard to troubleshoot sometimes.

I prefer git checkout support/0.5.0 which takes the stable branch perhaps including some additional commits or git checkout tags/v0.5.0 -b v0.5.0 which takes the tag to a separate branch. Both options make switching between branches much easier.

1 Like

@dgoetz thanks for the addition/correction.

my mistake: copy&paste error from our salt definition
this is what we are doing:

git checkout tags/{{ version }}

After the last step i.e. “icingacli module enable incubator” i am getting below message:

root@ubuntuvm:/usr/share/icingaweb2/modules# icingacli module enable incubator
Launching the run script /usr/share/icingaweb2/modules/director/run.php for module director failed with the following exception: Missing dependencies, please check

what does the GUI say?

in Configuration -> Modules -> image
its enabled

but where as

its not enabled

which Director version you have installed/activated?


hmm … for the moment I’m out of ideas.
We also use 1.7.2 and the required modules. Everything works fine.

Oh… thanks Stevie Sy.

No idea what to do… i have done all possibilities but no idea whats wrong :frowning:

From your screenshot it still looks like incubator being on version 0.3.0.

Yes, you are correct. how to upgrade it to 0.5 version??
that is the main problem of mine.
Please let me know do you have any solution?
thanks in advance!!

You can follow @stevie-sy instructions above for a git installation or update.

I personally prefer not to use git if the customer is not totally firm with it. So I would download the release version from https://github.com/Icinga/icingaweb2-module-incubator/releases, unpack and rename it in the module directory /usr/share/icingaweb2/modules.

This will get much easier when modules will be available as packages! But I do not know when!

1 Like

Thanks for the valuable inputs:
could you please let me know the steps how to do it. (on Ubuntu Machine)
As i am failing to do it with your link. thanks in advance!!

to get it to work you should first remove the old directory with

rm -rf  /usr/share/icingaweb2/modules/incubator

and then just copy the following block and paste it to your command line. Then it should work :slight_smile:

mkdir "$MODULE_PATH" \
&& wget -q $RELEASES/${MODULE_VERSION}.tar.gz -O - \
| tar xfz - -C "$MODULE_PATH" --strip-components 1
icingacli module enable "${MODULE_NAME}"

Thanks you very much!!!

It works for me :slight_smile: