Icinga Director Daemon DB configuration is not valid

Hi all,

after upgrading Icingaweb2 to the latest version I have some problems with the icinga director daemon:

● icinga-director.service - Icinga Director - Monitoring Configuration
Loaded: loaded (/etc/systemd/system/icinga-director.service; enabled; vendor preset: disabled)
Active: active (running) since Thu 2019-11-14 09:27:09 CET; 1s ago
Docs: https://icinga.com/docs/director/latest/
Main PID: 2233 (icingacli)
Status: “running, db: no configuration”
CGroup: /system.slice/icinga-director.service
└─2233 icinga::director: running, db: no configuration

Nov 14 09:27:08 systemd[1]: Starting Icinga Director - Monitoring Configuration…
Nov 14 09:27:09 icingadirector[2233]: Started by systemd, notifying watchdog every 5s via /run/systemd/notify
Nov 14 09:27:09 systemd[1]: Started Icinga Director - Monitoring Configuration.
Nov 14 09:27:09 icingadirector[2233]: DB configuration is not valid

by running “/usr/bin/icingacli director daemon run” the same error occurs.
But the director modul works fine. I can deploy configuration and it work.

Any ideas on this?

Thanks for your help!

Did you run the database migrations kickstart after upgrading?

1 Like

Hi Michael,

the problem has been fixed. But it seems like there´s an problem with updating icingaweb2.
We installed the icingaweb2 config directory to another location not “/etc/icingaweb2”. It seems like the environment variable ICINGAWEB_CONFIGDIR in the webconfig is not used by all modules.

As the director module seems to require the configuration at “/etc/icingaweb2” we created a symlink at /etc/icingaweb2 to our config directory now it works.

Thanks for your help!

1 Like

Sounds like a bug to me, would you mind creating an issue? :slight_smile:

1 Like

Hi Michael,

I will open an issue :).



I have the same issue on a fresh install of icinga2 -icingaweb2 and director.

Director works fine but the daemon background is stopped, a status icinga-director.service returns:
DB configuration is not valid

Any ideas?

Hi Patrick!

Did you try Michaels suggestion of running the database migrations kickstart after upgrading?

Or were you referring to the configdir issue? :slight_smile:

Hi @theFeu

i tried the database kickstart after upgrading. But at the moment the problem still exists.
My workaround is to move or delete the /etc/icingaweb2 directory after upgrading icingaweb2 and then create a symlink.
ln -s “my Icingaweb2 configdir” /etc/icingaweb2