Icinga check shows warning, but why

Hey all,
I got icinga2 v.2.11.1 and a windows endpoint with icinga agent 2.11.1
I got following message in icingaweb:
Icinga agent is running, but it says: “last zone sync stage validation failed at …”
How can I get rid of that warning message?

the client received a new config but cannot apply it because of an error.
c:\program files\icinga2\sbin\icinga2.exe daemon --validate on the client should tell you what’s wrong.

And have a look on your system time, the timestamps in your screenshot look strange (if it is a current screenshot).


Hi Robert,
I don’t get an error:

My timezones are correct. When I take a look into the history of that service, the 30th of October has been the first time when that service check turned into warning.

Since that time, it stays as “warning” in the dashboard.

I’ve just restarted the icinga agent on the windows endpoint: Now the warning looks like that:

But it still says “last zone sync stage validation failed” I don’t know why.

I had this once. I looks like the agent is validating the current config and this one is okay. The Staging config has a problem. I can’t remember what i have done to solve it, but the problem is a recent change in your configuration. Would be interesting if its possible to use “icinga2 daemon --validate” on the staging config.

Edit: i had this never again, maybe that something that was fixed in 2.11.2


for me it looks like my cluster problem Master-Master Cluster Sync Problem but it isn’t solved right now. After trying a lot of things and starting with a totally new ido I opend an issue on Github: https://github.com/Icinga/icinga2/issues/7642

Hope that your problem is different and you can find a solution soon.

The daemon on the agent logs a failed stage validation, and puts the path for further information - this essentially contains the output of a manual icinga2 daemon -C run. This works in a similar fashion as with the Icinga Director and its deployment views for config packages.

[2019-06-19 15:45:27 +0200] critical/ApiListener: Config validation failed for staged cluster config sync in '/var/lib/icinga2/api/zones-stage/'. Aborting. Logs: '/var/lib/icinga2/api/zones-stage//startup.log'

In order to fix the error and make it go away, actually re-deploy valid configuration.


If you had a cluster problem before, remove every synced configuration including the staged one and try again. If the config of the cluster is valid, then it should sync a working one again.

agent 2.11.2 didn’t solve the problem.
But I solved it by deleting api, icinga2.state and modified-attributes.conf
in C:\ProgramData\icinga2\var\lib\icinga2