Icinga 2 Windows Framework UsedPartitionSpace

Hello all,

I’m a bit confused…
i create a partitionSpace check and some server (not all) send me following result.

The Disks C:, D: and E: are correct but F: is not.

grafik

and if i check it on Powershell

A lot of headscratches

Hi, what is the file system of C, D or E? Maybe that’s the problem?

i dont think so

I mean if C is e.g. FAT/NTFS und F is ReFS (read in your screenshot) maybe the check has problem with the filesystem ReFS?

Maybe you check the filesize with cmdlets written e.g. here How to Get Free Disk Space in PowerShell? - ShellGeek

If it turns out, that the check doesn’t work correctly with ReFS you could create an Issue: GitHub - Icinga/icinga-powershell-plugins: A collection of Windows check plugins for the Icinga PowerShell Framework

ooohhhhhh i sew what you mean… this is a great tipp. i will check my other server and will reply the result

1 Like

No i have the same issue on NTFS on other Server.
Looks like he twisted the empty Size with the used Size

hmm… strange in our company everything is fine. If others have no ideas, maybe it is worth to create an issue

Yeah it is very strange and only on a few servers

Other example


In case you are using the latest version of the plugin, according to Invoke-IcingaCheckUsedPartitionSpace wrong result · Issue #273 · Icinga/icinga-powershell-plugins (github.com) the plugin checks the free partition space by default. Kind of confusing for a Plugin named UsedPartitionSpace though^^

Maybe play aroung with the mentioned alternatives in the github issue.
Why it outputs OK when only the single partition is check is also confusing to me.
Can’t help any further, as I’m not using the Framework plugins.

Yes I installed the latest one.

I fixed it.

your link was very helpfull.

grafik
i add this to the command. Now it works fine.

Closed

Hey @Granatelbart - please mark the answer that helped you fix your issue as the solution so it is marked as solved :slight_smile: