How to set the login language?

Hi Folks,
how can I set the Icinga2 default login language? As I go with my browser to the official Icinga2 demo page, I’m getting a english login language.

When I visit with the same browser my local Icinga2 instance, I get a german login page. How can I change my local Icinga2 instance to use english as default login language as well?

Many thanks in advance!

Best regards

Hi David,

each user can do that on their own settings page under https://monitoring-server.domain/icingaweb2/account

By default this is set to the Browsers setting.

I tried adding

language = "en_US"

to the [global] section of /etc/icingaweb2/config.ini but this does not seem to work reliable.
The language of the login page changed with nearly every reload and the login sometimes only worked on the second try, so this does not seem to be the correct way.
(assuming because I configured config_backend = "db" instead of config_backend = "ini")

Sadly there is no language option under https://monitoring-server.domain/icingaweb2/config/general

1 Like

Hi log1c,
thanks for the information so far. The individual user settings are good and also needed, but there have to be a default global language setting which language should be prefered as not set by the user (global overrides automatic).

I tried it as well and unfortunately it does not work for me at all. I would like to know how the Icinga2 demo site made it work. It seems to be a solution for this.

On a new instance of icingaweb2, I do not have to change any settings (nor do my users).

When checking my settings I see that it is set to the browser default (I am on Chrome)

I am on a bit dated version of Icingaweb2 2.7.x

Things I would check are:
1.) Your browser’s default language (setting varies by browser)
2.) Your user settings to make sure it’s not “hard” set on another language

Hi steaksauce,
I also appreciate your help as well. I should have told more about my background and my goal which I try to reach. My system language and browser language is indeed set to german, so thats fine when icingaweb detects automatically my default language. The goal which I try to reach is: is to have a default language set (deactivate auto detection by default). As we have many company branches in different countries, I would like to write a single language IcingaWeb2 howto. So I can be sure, all the branches when visiting IcingaWeb2 have the default language.

I’m using IcingaWeb 2.9.3. As the IcingaWeb2 demo page goes, it seems to work there, the auto detection of the language is deactivated. I get there by default english, instead of german.

Does anybody have a idea where I can set it as well?

Many thank in advance!

Best regards


pinging @theFeu :smirk:
I suppose someone in the Icinga team knows how this can be achieved :)?


I have seen this issue and meant to forward it to my colleagues (and then forgot - sorry!) we’ve got 2 new trainees with us since last week and stuff is kind of busy
I have now set a reminder so we will have a look at this one soon :slight_smile:


There’s no config option for this. Our demo just unsets a request’s Accept-Language HTTP header I suppose.