How to debug "ProvidedHook\Grapher" not found in /usr/share/icingaweb2"

My icinga setup is on a Ubuntu host

  • icinga web2 version 2.11.4
  • Grafana module 2.0.1
  • Grafana running on the same host v9.4.7 with influxdb v 1.6.4
  • PHP version 8.2.4

I have followed the grafana module configuration as seen on Mikesch-mp github page. Initially I was able to visualize a grafana plot in icinga, but suddenly I lost my plots when trying to add more plots. I have tried to remove the whole grafana module and re-install it again following the documentation but without any luck.
When looking in


I see this error message in syslog

Mar 30 08:31:34 curiosumunix icingaweb2[1132797]: ErrorException in /usr/share/icingaweb2/modules/grafana/application/controllers/DashboardController.php:47 with message: Uncaught Error: Class "Icinga\Module\Grafana\ProvidedHook\Grapher" not found in /usr/share/icingaweb2/modules/grafana/application/controllers/DashboardController.php:47    Stack trace:    #0 /usr/share/icingaweb2/library/vendor/Zend/Controller/Action.php(507): Icinga\Module\Grafana\Controllers\DashboardController->indexAction()    #1 /usr/share/php/Icinga/Web/Controller/Dispatcher.php(76): Zend_Controller_Action->dispatch()    #2 /usr/share/icingaweb2/library/vendor/Zend/Controller/Front.php(937): Icinga\Web\Controller\Dispatcher->dispatch()    #3 /usr/share/php/Icinga/Application/Web.php(290): Zend_Controller_Front->dispatch()    #4 /usr/share/php/Icinga/Application/webrouter.php(105): Icinga\Application\Web->dispatch()    #5 /usr/share/icingaweb2/public/index.php(4): require_once('...')    #6 {main}      thrown    #0 [internal function]: Icinga\Application\Web->Icinga\Application\{closure}()    #1 {main}

I would appreciate any pointer on what I have done wrong and how to continue to debug and be able to fix my grafana module installation. I should also mention that this is my first icinga installation so everything is very new to me.

Best regards Assar W.


Last week I ran into exactly the same issue and haven’t solved it yet.

This morning I found this issue Graphics not shown in Icinga Web 2 - Grapher not found · Issue #311 · Mikesch-mp/icingaweb2-module-grafana · GitHub
It seems there is a bug.

Keep in mind for Grafana module 2.0.1 you also need icingadb and icingadb-web. If you don’t have it you can downgrade to 1.4.2.


It seems like a confirmed bug now, so it is just to wait for the v2.0.2 release of the Icinga2 grafana module.
Thanks to all who are involved in the Icinga development