Graphite Installation for centos 6

hi all iam tried to install graphite in my centos 6 machine but my bad the graphs are not showing , i used this link for installation , can anyone send me to link for graphite installation with icinga2 for centos 6.


Try the steps - based on your DB change accordingly

Installation Graphite
yum install python-devel cairo-devel libffi-devel python2-pip python-psycopg2 gcc
pip install --upgrade setuptools pip
yum install python-carbon python-whisper
yum install graphite-web graphite-web-selinux

On DB Server:
sudo -u postgres psql -c “CREATE ROLE graphite WITH LOGIN PASSWORD ‘strongpasswordxxxxxx:)’”
sudo -u postgres createdb -O graphite -E UTF8 graphite
vi /var/lib/pgsql/data/pg_hba.conf add the below section
# icinga
local graphite graphite md5
host graphite graphite xxxxxxx/32 md5
host graphite graphite ::1/128 md5
systemctl restart postgresql

On Graphite Server:
vi /etc/graphite-web/
‘default’: {
‘NAME’: ‘graphite’,
‘ENGINE’: ‘django.db.backends.postgresql_psycopg2’,
‘USER’: ‘graphite’,
‘PASSWORD’: ‘strongpasswordxxxxx:)’,
‘PORT’: ‘’
/usr/lib/python2.7/site-packages/graphite/ syncdb
vi /etc/httpd/conf.d/graphite-web.conf
<Directory “/usr/share/graphite/”>

#Apache 2.4
#Require local
Require all granted
Order allow,deny
Allow from all

<IfModule !mod_authz_core.c>
# Apache 2.2
Order Deny,Allow
Deny from all
Allow from
Allow from ::1

systemctl restart httpd.service
systemctl enable carbon-cache
service carbon-cache start
http:// -> Graphite website should load
Icinga Web2 Server:
cd /usr/share/icingaweb2/modules/
git clone
mv icingaweb2-module-graphite/ graphite
chown -R apache:icingaweb2 graphite (check user of httpd process)
cd /etc/icingaweb2/modules/
mkdir graphite
vi config.ini
web_url = http://url_of_graphite/
Make sure to have correct permission as in httpd process

Icinga Master Server:
icinga2 feature enable graphite
systemctl restart icinga2.service
vi /etc/icinga2/features-enabled/graphite.conf
library “perfdata”
object GraphiteWriter “graphite” {
host = “graphite_Server”
port = 2003
enable_send_thresholds = true
systemctl restart icinga2.service
Icingaweb2-> Configuration -> Modules -> graphite -> Backend -> Graphite Web URL -> Enter the URL like “http://Graphite_Web/”