Grafana graphs 404 after upgrading to Grafana 8

I already figured this out, posting here as someone else will probably bump into this when Grafana 8.0 exits beta in a few weeks.

After upgrading from 7.5 to 8, I was confronted with this:

This is using the IFrame method in Grafana. The cause of this was actually really silly. Look under the module’s settings:


Remove the trailing / on the end of the Host. It’s redundant and the latest Grafana does not like that.


Thanks for sharing.

Which version of icingaweb2-module-grafana are you using? That was a fix for IFrame mode.

I upgraded to 1.4.2 while troubleshooting.