Global Master Zone not exported to all windows clients

Hi there,

I have quite a strange situation coming up.
Two windows servers (ad1 and ad2), both configured identically, incl.

  • operating system (Windows Server 2012 R2)
  • same icinga client installer file
  • same procedure (saving PS script in Director, Running after installation wizard configuration wizard on server, restarting)
  • same host config in director (really identically, compared by screenshots)

I defined a new command “powershell”.
This was exported and could be used by one of the servers (ad1) but not on ad2 (command powershell not found error).

Now I compared the configuration files of icinga client on those two servers and I see a difference:
ad2 has the global master zone missing:

object Zone "director-global" {
   global = true

as well as

const PowerShellIcinga2EnableLog = true;

which are missing.

icinga2.exe object list --type endpoint confirms this as the director-global zone is missing.

The zones.conf in both hosts contains:

object Zone "global-templates" {
    global = true

The PS script provided in the Director doesn’t create an icinga2.conf which includes zones.conf, you have to edit that by yourself.

The future Icinga for Windows framework takes care of that shortcoming.

Thanks for the hint…what I don’t get is why the one config has it, the other not as we didn’t edit them manually…? :man_shrugging:

I’m not familiar with the old PS script, but I’d guess that you can set a certain parameter which renders that global zone.

Thanks, you are right…there is a switch (which is not documented in the header of the script :wink: ).
But it would be great if the settings from the self registration API would be used as our global zones are set there as well…

Looking forward to your Icinga 4 Win framework!