Fresh install - problem with login

Hi,
2 days fighting with instalation and then with login problem debuging…

When I try to login ( Ive created 3 diffierent accout) - sill getting

Incorect username or password

and in syslog

May 15 15:03:00 icinga icingaweb2[6163]: Could not set php.ini setting hash_function = true. This might affect your sessions behaviour.
May 15 15:03:00 icinga icingaweb2[6163]: Could not set php.ini setting hash_bits_per_character = 5. This might affect your sessions behaviour.
May 15 15:03:00 icinga icingaweb2[6163]: Could not set php.ini setting hash_function = true. This might affect your sessions behaviour.
May 15 15:03:00 icinga icingaweb2[6163]: Could not set php.ini setting hash_bits_per_character = 5. This might affect your sessions behaviour.
May 15 15:03:03 icinga icingaweb2[6163]: Could not set php.ini setting hash_function = true. This might affect your sessions behaviour.
May 15 15:03:03 icinga icingaweb2[6163]: Could not set php.ini setting hash_bits_per_character = 5. This might affect your sessions behaviour.
May 15 15:03:03 icinga icingaweb2[6163]: Could not set php.ini setting hash_function = true. This might affect your sessions behaviour.
May 15 15:03:03 icinga icingaweb2[6163]: Could not set php.ini setting hash_bits_per_character = 5. This might affect your sessions behaviour.

Added those to my php.ini with no result.

icinga2 restart

May 15 15:11:25 icinga systemd[1]: Stopped Icinga host/service/network monitoring system.
May 15 15:11:25 icinga systemd[1]: Starting Icinga host/service/network monitoring system…
May 15 15:11:26 icinga systemd[1]: Started Icinga host/service/network monitoring system.

[2019-05-15 15:15:55 +0000] information/ExternalCommandListener: ‘command’ stopped.
[2019-05-15 15:15:55 +0000] information/CheckerComponent: ‘checker’ started.
[2019-05-15 15:15:55 +0000] information/ExternalCommandListener: ‘command’ started.
[2019-05-15 15:15:55 +0000] information/NotificationComponent: ‘notification’ started.
[2019-05-15 15:15:55 +0000] information/DbConnection: ‘ido-mysql’ started.
[2019-05-15 15:15:55 +0000] information/ConfigItem: Activated all objects.
[2019-05-15 15:15:55 +0000] information/DbConnection: Resuming IDO connection: ido-mysql
[2019-05-15 15:15:55 +0000] information/IdoMysqlConnection: ‘ido-mysql’ resumed.
[2019-05-15 15:15:55 +0000] information/IdoMysqlConnection: MySQL IDO instance id: 1 (schema version: ‘1.14.3’)
[2019-05-15 15:15:55 +0000] information/IdoMysqlConnection: Finished reconnecting to MySQL IDO database in 0.0147028 second(s).
[2019-05-15 15:16:05 +0000] information/WorkQueue: #5 (IdoMysqlConnection, ido-mysql) items: 0, rate: 0.35/s (21/min 21/5min 21/15min);

server:
icinga2 - The Icinga 2 network monitoring daemon (version: r2.8.1-1)

Copyright © 2012-2017 Icinga Development Team (https://www.icinga.com/)
License GPLv2+: GNU GPL version 2 or later http://gnu.org/licenses/gpl2.html
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Application information:
Installation root: /usr
Sysconf directory: /etc
Run directory: /run
Local state directory: /var
Package data directory: /usr/share/icinga2
State path: /var/lib/icinga2/icinga2.state
Modified attributes path: /var/lib/icinga2/modified-attributes.conf
Objects path: /var/cache/icinga2/icinga2.debug
Vars path: /var/cache/icinga2/icinga2.vars
PID path: /run/icinga2/icinga2.pid

System information:
Platform: Ubuntu
Platform version: 18.04.2 LTS (Bionic Beaver)
Kernel: Linux
Kernel version: 4.15.0-48-generic
Architecture: x86_64

Build information:
Compiler: GNU 7.3.0
Build host: lcy01-amd64-027

As you have icinga2 in such an old version, I assume that icingaweb2 is also not up to date.

So my advice would be to update both to the newest version, using the official Icinga repository.
See https://icinga.com/docs/icinga2/latest/doc/02-getting-started/#setting-up-icinga-2 for the details.

2 Likes

hi, thougt I got newest icinga version. Its worked after upgrade. Thanks

I can login now but no backend has been configured exception.

will try to sort out what is missine

Check if you have done all the needed steps for setting up Icinga Web2 and the databases:
https://icinga.com/docs/icinga2/latest/doc/02-getting-started/#setting-up-icinga-web-2

I suspect that you are either missing the ido database completely, where icinga2 will write it’s data to.
Or that you haven’t finished the setup of Icinga Web 2, where your define the various resources for db, authentication and so on.

Maybe even start completely fresh, if you haven’t done much/any configuration

1 Like

I did a lot of checks - changes maybe I forgot to undo something.
I did 2 databases… maybe have some uncosistent resources naming….

Where is stored icinga2 config? in /etc/icingaweb2 folder?

You need to take a look a different configs

I’d say check
/etc/icinga2/features-enabled/ido-mysql.conf
/etc/icingaweb2/resources.ini (you can check this via the webui under /icingaweb2/config/resource)
/etc/icingaweb2/modules/monitoring/backends.ini(you can check this via the webui under /icingaweb2/config/modules#!/icingaweb2/monitoring/config)
/etc/icingaweb2/modules/monitoring/commandtransports.ini (you can check this via the webui under /icingaweb2/config/modules#!/icingaweb2/monitoring/config)

2 Likes

Ok, got fully working Icinga2. Installed from scratch.

Didnt expected I have to use cli to add nodes and groups grrrr……

Thanks.

You are likely looking for the Icinga Director then.

Cheers,
Michael