First Notification Delay

Hello Everyone

I know this question was asked many times before, and there have been explanations that the behavior is not as it may be assumed…

First Notification Delay

What I want is for a 5 minute delay on any HOST or SERVICE up/down/crit before a notification is sent.

This would be AFTER the HARD state is achieved. So SOFT state for 60 second retry interval, 5 max check attempts, (which is now 5 minutes) and then once it goes HARD, i want ANOTHER 5 minutes from the first notification delay option.

I understand i can control this via the check attempts and retry however It would seem intuitive that “First Notification Delay” would solve this, but it doesn’t appear to work this way.

Notifications are still sent out instantly upon hitting HARD state

Does anyone know if this is fixed in a later build possibly? My details are below

Notification Interval = 0
Notification Delay = 5

Icinga Web 2 Version 2.8.2
Git commit 8a89839af94a247ee2149b2336c73b8251b477c0
PHP Version 7.4.22


Hi there and welcome.

Check the docs for how to set a delay via the config files:

In case you are using the Icinga Director (assuming because “First notification delay” is the label of the field) you have the same options for the input.
No unit means seconds, thus:

  • 5 → 5 seconds
  • 300 → 300 seconds (5 minutes)
  • 5m → 5 minutes
1 Like

Doh. Its in SECONDS!. So i would need 300…shoot

Thanks log1c

1 Like