/etc/icingaweb2/modules/director wasn't created

HI everyone!

I’ve just installed the Icinga2 Director module. Installation worked just fine, but somehow /etc/icingaweb2/modules/director wasn’t created. Therefore I can’t configure the DB resource. Any idea on why this could have happened? I tried to remove and re-install the module, didn’t work. The icingadb module-folder was created earlier today, worked without any problems.

OS: Debian 11.7
Icinga: 2.13.7
Icinga Director: 1.10.2

Thanks for your help! :slight_smile:

Welcome Julia

How did you install the director?

Can the webserver read the files?

Hi Dominik, thanks for your answer.
I installed the director via apt install icinga-director.

Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 1620 B of archives.
After this operation, 8192 B of additional disk space will be used.
Get:1 Index of /debian icinga-bullseye/main amd64 icinga-director all 1.10.2-1+debian11 [1620 B]
Fetched 1620 B in 0s (14.0 kB/s)
Selecting previously unselected package icinga-director.
(Reading database … 42026 files and directories currently installed.)
Preparing to unpack …/icinga-director_1.10.2-1+debian11_all.deb …
Unpacking icinga-director (1.10.2-1+debian11) …
Setting up icinga-director (1.10.2-1+debian11) …

When running apt list --installed, the icinga director is on the list:

icinga-director-daemon/icinga-bullseye,now 1.10.2-1+debian11 all [installed,automatic]
icinga-director-php/icinga-bullseye,now 1.10.2-1+debian11 all [installed,automatic]
icinga-director-web/icinga-bullseye,now 1.10.2-1+debian11 all [installed,automatic]
icinga-director/icinga-bullseye,now 1.10.2-1+debian11 all [installed]

but it’s no where to be seen on my machine- no files where created at all.

There’s also no director daemon / service.

What is the output of icingacli module list? You can check which files are installed by a package using dpkg -L <packages>