Error while installing icinga2 on RHEL 8.4

This is my first try to install icinga2 on RHEL (8.4) following Installation - Icinga 2.

Running subscription-manager repos --enable rhel-8-server-optional-rpms fails with this error:

Error: ‘rhel-8-server-optional-rpms’ does not match a valid repository ID. Use “subscription-manager repos --list” to see valid repositories.

Obviously not an icinga2 error. Is this an error in my environment or in the documentation?

Hi !

I guess it fails because you don’t have a valid RHEL subscription.
What does the output of the following Command say:
subscription-manager status

Does it look like this ?

   System Status Details
Overall Status: Unknown

System Purpose Status: Unknown

Then there is no subscription attached.

More information on how to activate a rhel subscription is found here.

Even with a Developer License it is needed to activate the subscription to use the only then available repos.



I have registered the server:

# subscription-manager status
   System Status Details
Overall Status: Current

System Purpose Status: Not Specified

And does then the enabling of the server optional repo work with the command ?

subscription-manager repos --enable rhel-8-server-optional-rpms

You can see if it worked with

sudo subscription-manager repos --list-enabled

Which are active !



Oh, My Bad … i investigated a little bit in the Red Hat forums i’ve blanked out that there was a change in the Red Hat Repo Structure. I think there is no server-optional-rpms anymore.

According to the following Post:

There is still the EPEL Part

dnf install"

And then the missing stuff might be included in

subscription-manager repos --enable codeready-builder-for-rhel-8-x86_64-rpms

I think this also might be helpful for the Service level and attachment,is%20enabled%20for%20this%20system.



Ok, the documentation will then need an update? Will you open an issue? (I could do it as well, however, I’m a RHEL novice)

No Problem, Thanks making that aware to us. i will raise in internal request for a change.

This might be the shortest way to resolve this in the Documentation.



1 Like

Seems to be already corrected. But isn’t updated in the actual Website.

You could take a look here.