Error when trying to create a Host Template


Just installed Icinga 2, Web and Director for proof-of-concept, but currently stuck on creating a Host Template thru Director:

Checking if I missed something on the setup or such. Rest of the details below:

Thank you!

the module versions are missing in your post.
goto https://your-icinga/icingaweb2/about
and post a screenshot.

how did you install incubator?


This are the modules installed:

As for incubator, I initially installed it using yum install icinga-php-incubator, but have an issue with Director setup not proceeding due to it detecting the Incubator version to be 0.18.0, despite yum list listing it as 0.20.0 as required by Director.

Googled the issue and I followed the solution from this: Icinga Director depends on the following modules, please install/upgrade as required - #16 by ndonahue . The setup proceeded and Director looks fine but currently have this roadblock. As per checking, the error appears to be happening on some other options as well (Services, Commands, etc.).

Thanks and regards.

dont use the director master branch.
why are icinga-php-library and icinga-php-thirdparty with dev suffix

please update to something stable

Thanks for the pointer! It seems I am in the right direction after updating PHP libraries to something stable since the form is now appearing (with textboxes, fields, etc.). But problem now is it seems the pages are just in an html “format”:

post the info page please:



Here’s the updated screenshot of the About page:

Note that I haven’t changed the director module from master as it seems the issue with the page not loading the correct formatting doesn’t just happen on Icinga Director but on Icinga Web 2 as well.

director is still at master not at 1.10.2
is there a special reason for that?


I haven’t touched Director since it seems it is not the issue anymore as the whole Icinga Web 2 has the formatting problem. Tested changing the version of Director and it still has the same issue:

yes but now we are on the same level…

whats the content of your application log?

did you reload the page with cache bypass?:

Wikipedia:Bypass your cache - Wikipedia.

also this is usually some problem with a module.
so a good start would be to deactivate everything and if icingaweb2 works again, activate everything step by step to narrow down the issue

Thank you. For the application log, all I can see are these ones, which seems no error appearing:

Also tried the bypass cache method to no avail. Tried deleting cache on Firefox itself but didn’t work as well.

When you say deactivate a module you mean this ones below right?:

log from:


and yes these modules…

icingacli module disable director

and so on

I think I got the module with the issue. Issue with formatting disappears whenever “icingadb” is disabled. Is it possible that the version I have is not compatible with the Icinga PHP libraries installed?

how did you install icingadb-web?
package? dev-package? github master? release?

I installed it using the method here (yum): CentOS - Icinga DB Web

For clarity, this is the currently installed package on my box:
Installed Packages
icingadb-web.noarch 1.0.2+165.gaaf3a7b-1693004606.el7 @icinga-snapshot-builds

why snapshot builds?
snapshot builds are not in any kind guaranteed to be working

Hi again,

Just followed the installation documentation for CentOS on the website. I think I should’ve been more specific with the package and repo thou :confused: .

Anyway, managed to remove then install the stable build of icingadb-web 1.0.2 and good news is UI seems to be good now and I’m no longer getting the PHP/Zend compatibility errors from before.

Problem now thou is the Director is detecting the DB schema as newer (since I used the “master” branch and all) with the message:

Regarding this, should I just drop the current “director” schema on the MySQL and re-run /usr/share/icingaweb2/modules/director/schema/mysql.sql? This is for initial setup and PoC so if there are any user (mine) records there, it should be ok to be deleted.

Thanks and regards

if there is nothing in it, you can drop and recreate it.
or you try to roll back:

Thanks Nick,

Worked like a charm :slight_smile: !

Marking this solved.

1 Like