Error when create Icinga Director Schema

Hi guys, i’m just start using Director.
I tried follow the installation guide in website but never worked.

When i tried create a new database with mysql on icinga and from another mysql server but always get this error:

Migration 0 failed (SQLSTATE[42S21]: Column already exists: 1060 Duplicate column name 'imports') while running CREATE TABLE branched_icinga_service_set ( uuid VARBINARY(16) NOT NULL, branch_uuid VARBINARY(16) NOT NULL, branch_created ENUM('y', 'n') NOT NULL DEFAULT 'n', branch_deleted ENUM('y', 'n') NOT NULL DEFAULT 'n', object_name VARCHAR(128) DEFAULT NULL, object_type ENUM('object', 'template', 'external_object') DEFAULT NULL, host VARCHAR(255) DEFAULT NULL, description TEXT DEFAULT NULL, assign_filter TEXT DEFAULT NULL, imports TEXT DEFAULT NULL, imports TEXT DEFAULT NULL, set_null TEXT DEFAULT NULL, PRIMARY KEY (branch_uuid, uuid), INDEX search_object_name (object_name), CONSTRAINT icinga_service_set_branch FOREIGN KEY branch (branch_uuid) REFERENCES director_branch (uuid) ON DELETE CASCADE ON UPDATE CASCADE ) ENGINE=InnoDB DEFAULT CHARSET=utf8
1 Like

Already fixed it.
For anyone have same issue:

  • Stop fresh install ver 1.10.0: You gonna facing another problem with import database.
  • Using ver 1.9.0 to install.
  • If you really want ver 1.10.0: Upgrade it from 1.9.0.
  • If you want see another problem on 1.10 following this guide to fix schema creation problem:
    open mysql schema with the path: /usr/share/icingaweb2/modules/director/schema/mysql.sql with your text editor find this line: branched_icinga_service_set
    There will be duplicate import mine already fixed:
    “imports TEXT DEFAULT NULL”
    remove one.

reminder: this need to be change befor create schema. If you already create on database need to delete database and re-create it.


Thank you soooooo much for this post. It probably saved me hours of late night tired-brain-not-working head scratching.

Another update after update version 1.10.1
I still have same error while impor in kick start:

Storing director_activity_log[] failed: SQLSTATE[42S22]: Column not found: 1054 Unknown column '0x' in 'field list', query was: INSERT INTO director_activity_log (object_name, action_name, object_type, old_properties, new_properties, author, change_time, checksum, parent_checksum) VALUES (?, ?, ?, ?, ?, ?, ?, 0x076ff9e381d6a90a65910ac3a63c1f007595b198, 0x) {array ( 'id' => NULL, 'object_name' => 'root', 'action_name' => 'create', 'object_type' => 'icinga_apiuser', 'old_properties' => NULL, 'new_properties' => '{"object_name":"root","object_type":"external_object","password":"01543e459fea1017"}', 'author' => 'administrator', 'change_time' => '2022-10-08 16:11:31', 'checksum' => ' o��֩ e� æ< ' . "\0" . 'u���', 'parent_checksum' => NULL, )} (DbObject.php:957)

Stay on same path like i mention earlier

Fixed in 1.10.2

Cherry picking from DbConnection: deprecate/replace quoteBinary() · Icinga/icingaweb2-module-director@bfda96f · GitHub for the time being works.

1 Like

Thank you for update i will try it on my lab.