Error restarting icinga2 following installation guide

Hi guys. I’m trying to setup my first Icinga2 installation following the guide step-by-step on:
Im installing on CentOS 7 and just went through the step on installing MariaDB and Enabling the ido-MySQL module:

# icinga2 feature enable ido-mysql
Module ‘ido-mysql’ was enabled.
Make sure to restart Icinga 2 for these changes to take effect.

When I restart Icinga2 using systemctl restart icinga2 I get the following error:

Job for icinga2.service failed because the control process exited with error code. See “systemctl status icinga2.service” and “journalctl -xe” for details.

If I disable ido-mySQL I can start icinga2 without issue so seems to be related to MariaDB or the dB?

I’m new to both linux and icinga2 so I’m pretty stuck. :stuck_out_tongue:

Any help appreciated.


Did you try the command “journalctl -xe” to see what error you get?
Did you setup the DB with the needed credentials and installed the DB schema?


1 Like

Hi Steve.

Thanks for answering my post. It seemed to be something with the credentials. Ended up removing all packages and starting completely over (also updating to MariaDB 10.4 instead on 5.4 available in CentOS7. Seems to work now so moving on with the installation.