Error in /var/run/icinga2/cmd/icinga2.cmd

hello all ,
iam facing this issue when i try to change the configuration from local command file which we selected during web2 setup to api based.

Hello,

did you disable command file usage in icingaweb2 after creating the api connection?
If not, just remove the configuration from /etc/icingaweb2/modules/monitoring/commandtransports.ini

Regards,
Carsten

1 Like

Most properly your command pipe isn’t enabled. You can verify it via:

icinga2 feature list

to enable it, please run:

icinga feature enable command

But keep in mind this feature is deprecated and it is recommend to use the REST API instead.

@rsx he changed his config to api :slight_smile:

1 Like

@Carsten ups, you’re right. Thanks

1 Like