Error enabling PNP module

Hello Team,

I have enabled the PNP module as per https://exchange.icinga.com/icinga/PNP

Although I am getting the below error

The requested URL /pnp4nagios/graph was not found on this server.

Any thoughts on how to proceed?

Thank you.

Regards,
Sanjeeth

Hello Team,

I have enabled the PNP module as per https://exchange.icinga.com/icinga/PNP

Those instructions include the sentence “The base URL for PNP (e.g.
/pnp4nagios) must be accessible on the webserver.”

Have you done that part? Is your web server configured to server the PNP
graphs from that location?

The requested URL /pnp4nagios/graph was not found on this server.

It seems it isn’t.

Any thoughts on how to proceed?

What configuration have you put into your web server to tell it how to serve
PNP graphs?

Here’s what I use for Apache:

Alias /pnp4nagios “/usr/share/pnp4nagios/html”

<Directory “/usr/share/pnp4nagios/html”>
AllowOverride None

    <IfModule mod_rewrite.c>
            # Turn on URL rewriting
            RewriteEngine On
            Options symLinksIfOwnerMatch
            # Installation directory
            RewriteBase /pnp4nagios/
            # Protect application and system files from being viewed
            RewriteRule "^(?:application|modules|system)/" - [F]
            # Allow any files or directories that exist to be displayed 

directly
RewriteCond “%{REQUEST_FILENAME}” !-f
RewriteCond “%{REQUEST_FILENAME}” !-d
# Rewrite all other URLs to index.php/URL
RewriteRule “^.*$” “index.php/$0” [PT]

Antony.

I am kind of lost now. Earlier “The requested URL /pnp4nagios/graph was not found on this server” this was displayed but now it asks for authentication. Basically the login to icingaweb reports en error as below
“This server could not verify that you are authorized to access the document requested. Either you supplied the wrong credentials (e.g., bad password), or your browser doesn’t understand how to supply the credentials required.”

I haven’t made any changes so far.

My web server has the link to /usr/share/nagios/html/pnp4nagios/

Regards,
Sanjeeth