Director unable to deploy config


I’m trying to deploy the Director config from the web interface but it gives an error message:
Unable to detect your Icinga 2 Core version (DeployFormsBug7530.php:70)

When I run the “icingacli director config deploy” command I get another error message:
ERROR: RuntimeException in /usr/share/icingaweb2/modules/director/library/Director/Core/RestApiClient.php:143 with message: CURL ERROR: Resolving timed out after 3000 milliseconds

What host is it trying to resolve?

The director health check gives me the Ok for everything:

but as you can see, the last successful deployment was in December 2020.
Before I got the web error message above, it used to say a deployment is still running.

My versions:
Icinga Web 2 2.8.2
Git Commit 8a89839af94a247ee2149b2336c73b8251b477c0
PHP Version 7.2.24
cube 1.1.0
director 1.8.0
doc 2.8.2
incubator 0.6.0
ipl v0.4.0
monitoring 2.8.2
reactbundle 0.7.0

I’ve updated both icinga2 and icingaweb2.

Is anyone able to help me troubleshoot this?


I was able to clear the issue, but now my director service keeps restarting constantly, giving this error message:

I’ve tried looking online but cannot see any resolutions.

DO you have a director or icinga2 process already running? Have you tried stopping the director process, then the icinga process, then the http server, confirm they are down, then start them all back up again?

Hi, I tried all of it but the actual solution was extremely my fault - I needed to add my host’s name to the hosts file. Now it deploys. Thanks