Director Import Error

Hello together,

at first some informations of my fresh install:

-Director version:
-Icinga Web 2 version and modules:
Version: 2.7.3
Modules: reactbundle, ipl, incubator, director
-Icinga 2 version:
version: r2.11.2-1
-Operating System and version:
Platform: Ubuntu
Platform version: 20.04.4 LTS (Focal Fossa)
-Webserver, PHP versions:
apache2, php7.3 (downgraded from 7.4)

So i´m configurating the director module and get the following error, when it should import the commands:

  • Storing director_activity_log[] failed: SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘0x’ in ‘field list’, query was: INSERT INTO director_activity_log (object_name, action_name, object_type, old_properties, new_properties, author, change_time, checksum, parent_checksum) VALUES (?, ?, ?, ?, ?, ?, ?, 0x3dbadfe9d83c82331022bc5108caa2784085454b, 0x) {array ( ‘id’ => NULL, ‘object_name’ => ‘director-global’, ‘action_name’ => ‘create’, ‘object_type’ => ‘icinga_zone’, ‘old_properties’ => NULL, ‘new_properties’ => ‘{“is_global”:true,“object_name”:“director-global”,“object_type”:“external_object”}’, ‘author’ => ‘*******’, ‘change_time’ => ‘2022-07-05 12:16:28’, ‘checksum’ => ‘=����<�3"�Qʢx@�EK’, ‘parent_checksum’ => NULL, )} (DbObject.php:934)

Does anybody know whats my mistake?
And can you give me an advise, how to upgrade my icingaweb2 version. I saw that its not the newest. When i was installing it, it didn´t take the newest Version avaiable, somehow.

Thanks for your answers and help

Greetings Sennin

how can that be a fresh install?
icignaweb2 is from 18 Oct 2019
icinga2 24 Oct 2019

follow the guide:
you need to add the Ubuntu Repository before installing icinga

1 Like

Thats what i´m asking myself.
I did the Install from a Youtube Guide. So i thought, all would be fine.

But i will update the versions an see if the error then occur again.

Hi Moreamazingnick,

i updatet my installation.
So my Icinga2 version is now: r2.13.4-1
And Icingaweb2 is now: 2.11.0
my php-version is also 7.4 again, as it was with the fresh ubuntu installment.

But my error with the Director is still the same. Do you have any solution for that?

Greetings Sennin

what is your director version?

Hi Moreamazingnick,

The Module says “master”.

Is that a problem?

Greetings Sennin

check out a release like 1.9.1

Hi Moreamazingnick,

to change the branch to v1.9.1 solved the Problem.
Thanks for your help.

Greetings Sennin

1 Like


i got the same problem with a fresh icinga2 / icinga-director install on Debian Bullseye.
Both was installed by apt install and i cant go back to 1.9.1:

root@icinga:/etc/icinga2/conf.d# apt list -a icinga-director
Auflistung… Fertig
icinga-director/icinga-bullseye,now 1.10.1-1+debian11 all  [installiert]
icinga-director/icinga-bullseye 1.10.0-1+debian11 all

Hi Alex,

sry for the late answer. Did you solve your Problem?
Like in my past Screenshots listet, take a look if the director is at the master branch. If yes then go in to the bash in the Module directory and use the Command “git tag”. That will list you all the Versions you can use.
Than you can use the Command “git checkout vx.x.x” to checkout the latest stable branch.

In the Webpage you will then see a Warning Message, that downgrading the Module is not supportet.
I did it anyways and after the latest Version 1.10.0 the Warning was gone.

Greetings Sennin

1 Like

yes, switching to another version solved the problem.