Director Deployment Problems

Hello dear icinga community,

I’m currently discovering a problem with the icinga deployment.
I provided a service & command but the deployment always fails. It doesn’t matter if i try to deploy a different machine or localhost. When i run "icingacli director config deploy --force --debug --benchmark
" there are no errors shown. But in the web gui I always get “Error: Validation failed for object 'win10 ’ of type ‘Host’; Attribute ‘check_command’: Attribute must not be empty”

All kinds of relevant logs and version info’s can be found in the attachments.
Thank you in advance for your assistance :slight_smile:

Debian Version
Deployment Log local.txt (12.6 KB)
Deployment Log.txt (1.9 KB)

icinga2.conf.txt (2.9 KB)

1 Like

Hi !

Well i think the error Message is relatively straight with your configuration error.

Validation failed for object 'win10 ’ of type ‘Host’; Attribute ‘check_command’: Attribute must not be empty”

There must be a check_command set on your win10 Host/Template definition.

Just as an example a Windows Template Host definition.

In your case i would use hostalive or ping4 instead of random.



fixed typo

check_random is a bad example if you don’t need a check then you should at least use check_dummy otherwise you will run into this error that no check_command is set.
Like “steaksauce” suggested correctly.


If you inherited or are setting up a weird environment like mine, where there are no host checks (instead, we assign “ping” as a service for whatever reason :roll_eyes: ), then you could add the check_dummy check with a status code of 0

But you probably do want a check there, and you probably don’t have random defined as a check command. (Apologies if you do, then it could be something else)


Thank you for your hint. I recreated the host-template, reassigned the check command & now it’s working.

Have a great day!

1 Like