Director configuration issue #7530

Hi Icinga team,

I have recently installed all the latest and greatest icinga2, icingaweb2 and director.
(icinga2 - The Icinga 2 network monitoring daemon (version: 2.11.3-1))

I have a primary master, and a secondary master with the standard 3 level set up. Master => satellites + agents.

When I execute a deploy in director I am getting a message regarding issue #7530 (screen shot attached). When I investigate I notice that this issue was raised on 23 Sep 2019

Has this issue been fixed, and if so what is the resolution please.

Kind regards
Peter Goudman

Tbh I think the linked github issue answers all your questions?!
It shows you how you have to adjust your setup to be correct for any icinga2 versions after 2.11.

I’m wondering why you even get that message. When you freshly set up a new system there shouldn’t be any zones configuration outside the zones.conf file, if I am not mistaken.

1 Like

Hi log1c,

wow that was a fast reply!

I have set up my zones and endpoints within director and that’s when it started throwing a wobbly.

When I look at #7530 it seems to suggest defining my zones in /etc/icinga2/zones.conf.

I am about to carry out the config changes as explained in the issue because my zones.conf has only my master zone defined. I thought keeping the satellite zones inside director would be the way to go, but this seemed to produce the bug message.

Before executing the suggested fix I have some questions.

  1. Do I delete the zones and endpoints in directory first.
  2. After the change I make to zones.conf do I have to import into director afterwards.
  3. After the change do I then restart the icinga2 instances on the masters?

Again thank you for being so responsive.

Kind regards
Peter Goudman

1 Like

Normally you use the command icinga2 node wizard when setting up a master or satellite.
On the satellite you will then have a complete zones.conf file with the master endpoint/zone and the satellite endpoint/zone.

On the master you have to manually add the satellite zones/endpoints.

This is explained in the docs:

To answer your questions:

  1. Tbh I’m not sure :smiley: Have done that only once a few years back.
    I would delete them from the Icinga Director, define them in the zones.conf and check with icinga2 daemon -C if the config is consistent.
  2. If all works you then can import the zones with the Icinga Director kickstart wizard
  3. yes

Just for clarification, zone and endpoint objects need to be configured in zones.conf only is only valid for master and satellites but not for agents if they are configured as hosts in director.

1 Like

Hi log1c,

The issue is fixed.

  1. un-assigned all hosts that were using a satellite zone to master.

  2. deleted the satellite endpoints from director.

  3. deleted the zones from director.

  4. deployed the updates

  5. updated /etc/icinga2/zones.conf to include my satellite endpoints and zones.

  6. checked my configs (on primary and secondary masters)

     icinga2 daemon -C

    At this point on I received some errors regarding redefinition of the satellite
    zones so I removed them from

  7. Checked the config again.

     icinga2 daemon -C

    All good this time!

  8. Imported my newly defined zones using kickstart on the Primary Master

     icingacli director kickstart run
  9. Crossed my fingers and navigated to icinga director.
    Bingo! All zones, endpoints present and correct sir!

  10. Finally a deployment to test. All worked fine, no errors reported.

Many, many thanks to the Icinga team & especially log1c for his quick response.

Nice one!


Nice one, happy it worked for you!
Please be so kind a “close” the thread by picking a solution, so other know the problem is resolved :slight_smile:

1 Like