Delete vSphere host

Hi All!
I have installed the vSphere module on my ICINGA2 installation
.
I have correctly added 2 ESX servers and I can see all the VM inside these hosts.
Now I want to delete one of the ESX server but the delete button do not work.
I I try do delete the HOST - the delete button is present but when pushed - nothing happens!
P.

Hi @picoroma,

Did you have a look at the logs or could track the response of the delete action with the developer tools of your browser? We need more information on what is going wrong in order track this down.

All the best,
Eric

1 Like

I have enabled the developer tools.
Not error appear - but some warning into CONSOLE (when I push on DELETE):


But I think that this cannot be the reason…

HI, deleting is also not working on my site. Haven’t found the reason yet.

Anything in the icingaweb2 log? I remember a problem like this for a customer, solution was to install a missing php package which was required for one of the required modules.

1 Like

Where is this log located ?
I have checked the phpmodules needed and seems that all necessary modules was installed.
At the beginning I has a problem Adding the server - And this was due to a missing PHP module.
I have installed and the ADD procedure works fine.
But now Is not possible to delete it.
Screenshot_13

I noticed some problem with the vsphere deamon…
into the syslog I have:

It seems that this deamon stop & start automatically…

I’m having this problem:

Applied the Workaorund.
Now deamon it’s stable running.
But still cannot delete the HOST

Hello All,
I know this is an old post but it does not have a resolution to the problem. Does anyone have a fix to this post? I am also having problems with deleting vCenter server out of the vSphere module.

Hello @picoroma,
Did you every find a fix to this problem?

Many thanks
Alex