Couldn't connect to the Icinga 2 API: Failed to connect to ::1: acces denied

I am new to icinga. i ve Installed Icinga 2.
i am nw setting up icingaweb 2 and got this error message. checked my conf files and I am sure my password ist true. in the future list ist api activ.
can anyone help me


please show the installed versions of Icinga 2 and Icinga Web 2. Also, did you verify that the API is reachable with the given connection details? Please post the output of it too.


Hi Michael

1.icinga2 version
icinga2 - The Icinga 2 network monitoring daemon (version: r2.10.5-1)

2.the API is reachable with root and also with my own API user.

Icinga 2

Hello from Icinga 2 (Version: r2.10.5-1)!

You are authenticated as root. Your user has the following permissions:

  • *

More information about API requests is available in the documentation.


okidoki, then there are 2 things I can think of:

  • localhost instead of ::1
  • SELinux - try installing the icinga2-selinux and icingaweb2-selinux packages or set SELinux to permissive


  1. localhost instead of ::1
    that´s what I did

  2. SELinux
    icinga2-selinux and icingaweb2-selinux already installed.

Try instead of localhost, might be PHP doing some magic lookup here.

just tried it, but it’s still the same

Try disabling SELinux to mitigate the issue further. Is Icinga Web 2 running on the same host as Icinga 2?

yes, both are on the same host

it worked out after disabling SELinux
thank you!

Check messages and the audit log. It’ll typically have a suggestion on how to allow that through even if the provided package wasn’t getting the job done. That’s if you want selinux anyway. Keeps your infosec guys happy.

1 Like

In case someone else runs into this and still wants to leave SELinux enabled


semanage port -a -t http_port_t -p tcp 5665


installing the icingaweb2-selinux and icinga2-selinux packages should be sufficient to setup the SELinux rules as well.