Configure npn for icinga2 on redhat8

Hi team,
actually i do installation for icinga2 and icingaweb2 on RHEL8 and after installing npn and configure it , i got this error

i run npn verification from server side and for that
perl verify_pnp_config --mode=bulk+npcd --config=/etc/icinga2/icinga2.conf --pnpcfg=/usr/local/pnp4nagios/etc/
[INFO] ========== Starting Environment Checks ============
[INFO] My version is: verify_pnp_config-0.6.26-R.44
[INFO] Start Options: verify_pnp_config --mode=bulk+npcd --config=/etc/icinga2/icinga2.conf --pnpcfg=/usr/local/pnp4nagios/etc/
[OK ] Running product is ‘icinga2’
[INFO] Reading /usr/local/pnp4nagios/etc//process_perfdata.cfg
[INFO] Reading /usr/local/pnp4nagios/etc//pnp4nagios_release
[OK ] Found PNP4Nagios version “0.6.26”
[OK ] Configured User is ‘icingaadmin’
[CRIT] User icingaadmin does not exist

although i didn’t add user with name “icingaadmin”
i just create icingaweb2 and icinga for mysql ido , i valid this two files
Reading /usr/local/pnp4nagios/etc//pnp4nagios_release
PKG_REL_DATE=“08-21-2017”
PKG_VERSION=“0.6.26”
PKG_NAME=“pnp4nagios”

Configure Arguments

CONFIGURE_ARGS=

/usr/local/pnp4nagios/etc//process_perfdata.cfg

pnp4nagios–0.6.26

Config File for process_perfdata.pl

More info on RRDtool can be found at www.rrdtool.org

process_perfdata.pl timeout in seconds

TIMEOUT = 15

Use RRDs Perl module

USE_RRDs = 1

Path to XML/RRD files

RRDPATH = /usr/local/pnp4nagios/var/perfdata

Location of RRDtool binary

RRDTOOL = /bin/rrdtool

Location of PNP config files

CFG_DIR = /usr/local/pnp4nagios/etc

Use a single RRD database per service

one or more datasources per RRD database

RRD_STORAGE_TYPE = SINGLE

Use multiple RRD databases per service

one RRD database per datasource.

RRD_STORAGE_TYPE = MULTIPLE

RRD_STORAGE_TYPE = SINGLE

Max. interval between samples/updates

RRD_HEARTBEAT = 8460

File with RRA options used to create new RRD files

RRA_CFG = /usr/local/pnp4nagios/etc/rra.cfg

Interval at which PDPs are generated

RRA_STEP = 60

LOG_FILE = /usr/local/pnp4nagios/var/perfdata.log
LOG_LEVEL = 0
XML_ENC = UTF-8

Use this option to reduce disk I/O

XML_UPDATE_DELAY = 0

RRD_DAEMON_OPTS =

STATS_DIR = /usr/local/pnp4nagios/var/stats

PREFORK = 1

GEARMAN_HOST = localhost:4730
REQUESTS_PER_CHILD = 10000
ENCRYPTION = 1
KEY = should_be_changed

can you please support me how to validate this user ?

Hello,

The PNP module for icingaweb2 is makred as depcreated and will not be developed anymore. Better go for graphite or influxdb nad use the modules that are available for them.

Regards,
Carsten

Thanks for info ,
do you have good doc for graphite installation and configuration for RHEL8 , as i tried this first and i faced a lot of problems , so i looked for npn .

Regards,
Eman

I normaly install influxdb. easier to install and easier to maintain :slight_smile:
Check the howto section, i think there is one for graphite (centos7, but should work for 8 too)

Regards,
Carsten

actually i follow this doc : https://monitoring-portal.org/woltlab/index.php?thread/40288-icinga2-with-influxdb-and-grafana-howto/
but i face issues with grafana ,
do you have another mosule we can configure on influx to show the graphs /

Thanks, Eman

I wrote one on setting up graphite on rhel8 a while back: A distro agnostic guide to Graphite with venv (examples: RHEL8, Debian10, Ubuntu18)

I’ve actually switched to InfluxDB and the Grafana module since then, though. I would say InfluxDB is a far superior TSDB to Graphite (my opinion), but the Grafana module for Icinga is going to take more levels of configuration than Graphite’s (which kinda just works). If you’re stuck somewhere, let us know and we should be able to guide you.

1 Like