Config.ini does not exist

Good morning, sir,

I use the integration module for nagvis and for the config.ini I need to add , modify a file named config.ini but it’s not in the folder where it should be or I can’t find it can you help me or tell me where the file is

The only file of that name I can think of associated with Icinga is in
/etc/icingaweb2, however I’m not at all sure that’s the file you mean.

The following information would be helpful in order to answer you better:

  1. What change/s are you expected to make to this config.ini file?

  2. What instructions are you following telling you to do this?

  3. Are you certain that this config.ini file is associated with Icinga and not
    with Nagvis?

And, on a completely spearate note, I am very interested if you have been able
to get Nagvis working with Icinga2, so please point me at whatever
documentation you have found indicating how to do this.

Thanks,

Antony.

in this file I have to indicate there the default map that it has to load from icinga but in the documentation of the modules it tells me to go to modify the config.ini file found in the folder of config of icingaweb2 /modules/nagvis/config.ini but it is not there . and about how to make to interface the two I just found a module on github

So, you have done either one or the other of:

A
cd /usr/share/icingaweb2/modules
git clone https://github.com/Icinga/icingaweb2-module-nagvis.git nagvis

B
cd /usr/share/icingaweb2/modules
wget https://github.com/Icinga/icingaweb2-module-nagvis/archive/v1.1.1.zip
unzip v1.1.1.zip
mv icingaweb2-module-nagvis-1.1.1 nagvis

and then

icingacli module enable nagvis

Please show the output of:

ls -al /etc/icingaweb2/modules/nagvis

Regards,

Antony.

Hi,

if that file doesn’t exist, just create it and add the content.

Cheers,
Michael

if i create the file it doesn’t work

Please give more details than “it doesn’t work”.

  1. What doesn’t work? What command are you running which fails?

  2. How doesn’t it work? Do you get an error message on the console or in
    any relevant log files?

  3. Show us the output of the two commands:

ls -al /etc/icingaweb2/modules/nagvis

cat /etc/icingaweb2/modules/nagvis/config.ini

Regards,

Antony.

1 Like

re

int fact the command cat tell juste the file doesn’t exist and if icreate the file he have nothing not error , the void. and for th ls command il tell juste the link to the original folder

Okay:

  1. please copy and paste the command you are using to create the file and to
    add the necessary contents

  2. Please copy and paste the output of “ls -al /etc/icingaweb2/modules/nagvis”

  3. Please give some details of the problem you are encountering. You say “it
    doesn’t work”, but what doesn’t work, and how do you know it doesn’t work?

Basically imagine you are in our position, trying to understand exactly what
you’ve done and possibly re-create it so we can see the problem.

Give us enough information to do that.

Antony.