Command work in cmd but in director/icingaweb fail with error free(): double free detected in tcache 2

  • Director version (System - About):1.10.2
  • Icinga Web 2 version and modules (System - About):2.11.4
  • Icinga 2 version (icinga2 --version):r2.13.7-1
  • Operating System and version:Debian 11 Kernel 5.10.0-21-amd64
  • Webserver, PHP versions:Apache 2.4.54 PHP 8.2.3

Hi, firstly - this monitoring ecosystem is great, thank you for this!

I prepairing single icinga monitor system in template virtual machine.
Once I was almost done, I was made a virtual machine copy to test in real world.

When I was change hostname I run into problems. Most of them I can trace and fix, but the last one is too deep inside. I have no idea.

Command from Inspect:

'/usr/lib/nagios/plugins/check_nrpe' '-A' '/etc/icinga2/pki/cert_nrpe/ca.pem' '-C' '/etc/icinga2/pki/cert_nrpe/cli.pem' '-H' '' '-K' '/etc/icinga2/pki/cert_nrpe/cli.key' '-c' 'checkcpu' '-a' 'time=25m!!time=15s!!time=5!!crit=82%!!warn=60'

Command is created in director from external script.
The error come when service applying to host:

free(): double free detected in tcache 2
<Terminated by signal 6 (Aborted).>

What is most confusing - rendered comand by Inspect is working fine in cmd.

The same command work before I deleted old certificates and made new with icinga2 api setup
I don’t have any glue… :sleepy:

Thank for any help.

Hi & welcome,

Trying it manually means executing as user root, but icinga executes the check as user nagios or icinga (depending on your distribution). For testing I always recommend to switch to icinga’s user first e.g.:

sudo -u nagios bash

and try i again you’ll get the same result as with icingaweb.

Great, thats it!
I missed to change cert ownership to nagios
Many thanks!