Check_nwc_health timeout after 20 seconds

Hi Team,
I am trying to use check_nwc_health plugin for monitoring the network components performances.
I downloaded the plugin from the console labs :

Attaching the commands.conf for references.Conf.txt (10.1 KB)

In UI, we are getting timeout error, where as in cli am getting the right output.

I am attaching both screenshots for references.

Much appreciated if i could get some help in resolving this issue.


plugin error

Can i get some immediate help here…

Hallo @rajivram, can you post the configuration of your CPU_Load service here Please?

Hi Yonas,

Please find the services.conf details as requested.Services.conf


Anyone has experienced similar issue? If yes, could you please help me here…


what happens if you run the command with the icinga user and not with root? Also what happens if you set the check timeout higher in your service definition?

We have in our company sometimes similar issues with some kind of cisco hardware. Because the hardware needs longer to answer than the defined check-timeout is. Especially the hardware is fully working (cpu load higher than 80/90%).

It could also be dependent on it how many checks with nwc you are running parallel on your server and/or how often you run nwc with diffrent paramaters/modes (e.g. interface, hardware health, etc.)

Hi Stevie,

I followed below steps for deploying the check:

cd /tmp
tar -xvzf check_nwc_health-
cd check_nwc_health-
yum install -y perl-Net-SNMP perl-Data-Dumper perl-Module-Load
./configure --libexecdir=/usr/lib64/nagios/plugins/contrib --with-nagios-user=icinga --with-nagios-group=icinga
mkdir -pv /usr/lib64/nagios/plugins/contrib
make install
ls -la /usr/lib64/nagios/plugins/contrib/check_nwc_health
sudo -u icinga /usr/lib64/nagios/plugins/contrib/check_nwc_health -H localhost --servertype linuxlocal --mode interface-health

Do you think this line causing the issue??


If you can run the check with the root user the compiling worked fine. Usually you should test every check with the icinga/nagios user and not with the root user. That means if the access permissions are set correct incl. systems like SELinux or AppAmor (if used and configured) :wink:
if this is set correct than check the next things: In your case the network device is fast enough to answer. If not try to set a higher check-timeout in your service check.
And what happens if many checks are running parrallel? Has your icinga server enough ressources available to run many checks? Bash commands like (h)top are your friend in this situation.

Hi Stevie,

I ran the command icinga user.
please find below results:

[root@TRVUSTMMVLMON01 check_nwc_health-]# sudo -u icinga /usr/lib64/nagios/plugins/check_nwc_health --hostname --protocol 3 --username emadmin --authpassword ‘iCinga!56v3’ --authprotocol SHA --privprotocol AES --privpassword ‘SnmP!v234’ --mode cpu-load
OK - cpu cpu R0/0 usage (5 min avg.) is 0.00% | ‘cpu_cpu R0/0_usage’=0%;80;90;0;100

That means the check is working correctly. So as I wrote you have to check the other things on your icinga server an/or your infrastructure

But stevie, this command i ran from the master server…then what is causing time out when it comes to the Icinga UI?

SELENIUX is disabled.

Hii @rajivram, Sorry for not answering quickly, but maybe it’s because it didn’t work.

Your command args definition:

 "--privpassword" = "snmpv3_priv_key"

vars.snmpv3_priv_key = "SnmP!v234"

you forgot the $…$ signs. "--privpassword" = "$snmpv3_priv_key$"


Thanks Yonas.

That really helped.

1 Like