CHECK_NRPE: (ssl_err != 5) Error - Could not complete SSL handshake

i’m working with 2 icinga instance:
1-icinga 1 (1.1.14) with about 900 service check (check_nrpe v.2.14) - centos 6.10
2-icinga 2 (2.6.3) with about 900 service check (check_nrpe v3.2.1) - centos 7.6.1810

3-i’ve installed today 17/4/20 on centos 8 latest versione of icinga with check_nrpe v3.2.1

so check_nrpe drive me crazy because:

on instance icinga 1 and 2 works very well but on instance 3 centos 8 same version of check_nrpe of instance 2
i’ve this error:

/usr/lib64/nagios/plugins/check_nrpe -d2 -t30 -H SERVERNAME -c uptime -p 5666
CHECK_NRPE: (ssl_err != 5) Error - Could not complete SSL handshake

in instance 1 and 2:

/usr/lib64/nagios/plugins/check_nrpe -t 2 -H SERVERNAME -c uptime

\SERVERNAME has been up for: 317 day(s), 6 hour(s), 32 minute(s), 59 second(s)

don’t care about command to measure uptime as check_nrpe i use to monitor several thins and i’ve
about 300 services.

thanks, livio.

PS:allowed host are ok on SERVERNAME

i 've solved in this way consider in order to use client check_nrpe(v2) and check_nrpe(v3).
so the situations is,

  1. some old server have icinga++ and check_nrpe(v2), it’s impossibile to update
  2. new server need icinga++ and check_nrpe(v3) up to date

so my monitor instance must up2date but need to monitor old icinga++ and check_nrpe.

i’ve solved only to copy binary centos(7) check_nrpe on a new fresh up to date centos(8) instance with latest build of icinga module for vshere etc.
the binary must be copied to the folder where is the check_nrpe binary with another name.
launch the new binary name at it ask for library that fortunatly have a different name, after 3 or 5 library copied from older instance the binary works as expected.

so i’ve configured a template for old server and all works fine.