Check_mssql_health Username from domain in icinga director


I have installed the check_mssql_health like this tutorials

I use this check from linux monitoring server on my windows host not in agent because check_mssql is not exist on windows agent

But I get always this error

CRITICAL - DBI connect(';server=my-sql-server;encryptPassword=1',​'mydomain\servicemonitor',​...)
 failed: Server message number=18456

When I try this in command line from linux monitoring server I get the same error. But When I change the parameter --username=mydomain\servicemonitor with --username=“mydomain\servicemonitor” it work.

What is the right syntax for the username in icinga director?

Thank you for help

I had similar issue

This is working with me


Only thing you need to be careful of is the password. If you have a $ in the password escape with another dollar - so basically if your password is P@$w0rd you need to use P@$$w0rd

nice. Thank you. I have set up a new variable mssq_user_domain and set this in the username field. This work.