Check-Disk remains critical after enlarged drive

Hello community,

i´m new here and startet with an fresh icinga2 installation about a month ago.
So first up my setup infos:

  • Icinga Web 2 version 2.8.2
  • Used modules and their versions (System - About)
    director v1.8.0, x509 v1.0.0 , incubator v0.6.0, ipl v0.5.0, reactbundle v0.9.0
  • Web Browser: Chromium Edge
  • Icinga 2 version r2.12.4-1
  • PHP version PHP 7.4.3
  • Server: Ubuntu 20.04.2 LTS on VMWare Host

My Test-setup is running very good so far.
Actually i have one little Problem with my Check_Disk Service checking my Disk from the Icinga-Server. It changed critical after less than 20% space on the drive.
So i thought, thats no big deal. Its an VM on our VMWare Cluster and so i can enlarge the drive.
So i did enlarge it from 40GB to 60GB.
But my Disk_Check Status doesn´t change to green.

Have anyone a guess, whats the Problem?

Greetings Sennin

Can you tell us what “command_endpoint” is set to for that service check?

Are you monitoring only the machine which Icinga is currently installed on, or
are you using Icinga on one machine to monitor one or more other machines?


Hi Antony,

i configured the disk-command in the director und then created a Service “Disk-Check”.
This Service only Checks the Icinga-Host.

I also used the Icinga-Agent Plugin for Powershell. Currently i only setup one Host there.
The Services for the Windows Host are different.
For Win i configured this commands and they work fine:
service-windows (especially netlogon)

This Commands are in one Service-set and the Set is configured in a Windows-Host-template.
So every future Windows Machine gets the same sets, just by putting them in the Host-template.



today the status of my Disk-Check is green. Deleted some Files, which i have installed for testing.
But the Size of my drive is still not correct.



I’d assume you did not extend your partition.

Hello Roland,

my Partition has the amount of 60 GiB.

So increasing the Storage has worked, by VMWare.

Anways my Icinga now has this output:

So i think that the used memory in percentage is correct. But the shown value isn´t.

As we have many VM-Servers, this maybe is a problem in the future.
But i don´t know if the Windows-Disk-Check will work fine. Maybe yes, cause it is executed by the Icinga-Agent. And not from My Icinga-host.



Yes, you were able to increase the disk, but your partition on that disk is still about 40 GB. Please verify with

fdisk -l /dev/sda


If the partition size is recognized correctly, maybe the filesystem-size hasn’t been adjusted (resize2fs, xfs_growfs, …).

The output of:

df -h -T 

would give a good hint (the lines of the partition from the disk).
But please be careful:
Depending on the partition location on the disk, it isn’t always easily possible to resize the filesystem.


Hi Roland,

i did this check again. And the Output is still the same:

So my Drive is 60GiB, but my Partition and Filesystem is not.
You´re right. thats on me.


I Think you´re right. The Command output:

I think the Filesystem is the problem.
So how do adjust this?



Your sda2 respective sda5 is still 39,5 GB. Hence, you need to increase both partitions and finally extend your filesystem.

Yes you´re right,

thats on me. Mistaken Partition and Drive…

So i already found a good Guide to do it.
I´ll report, when its done. Hopefully all runs well and i don´t have to start all over again.




so i´ve done it after the Guide postet here:

filesystems - How to to resize an ext4 partition from the command line? - Unix & Linux Stack Exchange

After a little Problem at the End with resize2fs and solved this, it looks good now:

(The Guide did the Resize Command with /dev/sda, so i thought it have to be sda2. But thanks to ‘homerjay’ i saw that it have to be sda5)

And Icinga already noticed the Changes:

Thanks again.



1 Like