Check command not working

Hello guys,
Yesterday i have integrated a new icinga environment in my network.
I have added a check command of my own to icinga2(which is fully working on the second environment),
however, now icinga director does not recognize that i have added the check command, and also when adding manual configuration using that check command, monitored services shows as unknown state on icinga web.
Would appreciate your help.

Thanks in advance,

Also in my mysql db in the icinga db under icinga_commands table i do see the added check command

Hi and welcome to the show!

Try rerunning “Director Kickstart”. You can always run it when you add something to the configuration files and most objects (but not all) will be imported as “external objects”

how can i rerun it?
i have installed director from source
and basically enabled it and in the web stored the configuration under the configuration tab of the directir module.
needless to say that other check commands(like those install via nagios-plugins-all) are indeed recognized and are for fact usable

Unfortunately the Director is only available as source installation. There is no package, yet. Please keep in mind to always use a release version instead of the development master.

You can use:

icingacli director kickstart run

or klick through in the “Infrastructure” menu item of Director.

Yes rerunning has loaded it to director.
Thank you very much.

@even could you please tick the “solution” checkbox in the post that solved your problem? This way you give kudos and show other users that they don’t need to read through the whole thread just to find that you don’t need any more help. Thanks.

I have marked the solution