Change themes shows Error --> Uncaught Error

When i Change Themes for example from Dark to Light or the other way it shows an Error:

icinga2 - The Icinga 2 network monitoring daemon (version: r2.13.2-1)

Copyright (c) 2012-2022 Icinga GmbH (https://icinga.com/)
License GPLv2+: GNU GPL version 2 or later https://gnu.org/licenses/gpl2.html
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

System information:
Platform: Debian GNU/Linux
Platform version: 11 (bullseye)
Kernel: Linux
Kernel version: 5.10.0-13-amd64
Architecture: x86_64

Build information:
Compiler: GNU 8.3.0
Build host: runner-hh8q3bz2-project-298-concurrent-0
OpenSSL version: OpenSSL 1.1.1n 15 Mar 2022

Application information:

General paths:
Config directory: /etc/icinga2
Data directory: /var/lib/icinga2
Log directory: /var/log/icinga2
Cache directory: /var/cache/icinga2
Spool directory: /var/spool/icinga2
Run directory: /run/icinga2

Old paths (deprecated):
Installation root: /usr
Sysconf directory: /etc
Run directory (base): /run
Local state directory: /var

Internal paths:
Package data directory: /usr/share/icinga2
State path: /var/lib/icinga2/icinga2.state
Modified attributes path: /var/lib/icinga2/modified-attributes.conf
Objects path: /var/cache/icinga2/icinga2.debug
Vars path: /var/cache/icinga2/icinga2.vars

PHP:
PHP 7.4.28 (cli) (built: Feb 17 2022 16:17:19) ( NTS )
Copyright (c) The PHP Group
Zend Engine v3.4.0, Copyright (c) Zend Technologies
with Zend OPcache v7.4.28, Copyright (c), by Zend Technologies

I used Firefox and Edge and both show the same Problem

Hi,

please take a look here.

thx for the answer. But i am really new to ICINGA and i am absolutely not a professional into it.
I activated the “migrate” Module" and then run the “icingacli migrate preferences” Command in CLI but i get stuck here again:

root@icinga01:~# icingacli migrate preferences
ERROR: Icinga\Exception\MissingParameterException in /usr/share/php/Icinga/Cli/Params.php:185 with message: Required parameter ‘resource’ missing

Can you help me to get it work?

you are using icinga director 1.7.2, which is very old, so I assume you recently upgraded icingaweb2.
from which version did you upgrade your icingaweb2 from?
what’s the version number of your migrate? (icignaweb2/configuration/modules/migrate)

Honestly idk the previous Version of Icingaweb2 i upgraded from.

My Migrate Version is 2.10

grafik

  1. First you have to setup a database and configure a resource for it at Configuration -> Application -> Resources (tab). If you’ve got already one which you’re using as authentication backend, you can skip this and use that instead in the next step.
  2. Then go to Configuration -> Application -> General (tab) again and choose the resource as configuration database. Save.
  3. Now run icingacli migrate preferences

After that you and any other user of your Icinga Web should be able to change the preferences just fine.

1 Like

Thank you very much now it is working… Appreciate your help.