Certificate error while installation


** Icinga for Windows Management Console **
** Copyright (c) 2022 Icinga GmbH | MIT **
** User environment DESKTOP-SHJOTON\Administrator **
** Icinga PowerShell Framework v1.9.2 **


What do you want to do?

[0] Base Installation
[1] Component Manager
[2] Settings
[3] Overview
[4] Icinga Shell

[x] Exit [c] Continue [h] Help [l] Commands [m] Main

[Error]: Failed to create certificate.
Arguments: pki save-cert --trustedcert C:\ProgramData\icinga2\var\lib\icinga2\certs\trusted-parent.crt --host 10.0.0.55 ::1 --port 5665
rror:critical/cli: Too many arguments. At most 0 arguments may be specified.
[Error]: Unable to connect to your provided Icinga CA. Please verify the entered configuration is correct.
[Error]: Failed to enter menu “Start-IcingaForWindowsInstallation”. Error "Invalid IP-Address format. For IPv6 and/or port configuration, the syntax must be like [ip]:port

[Warning]: The package “agent” with version “2.13.5” is already installed. Use “-Force” to re-install the component
[Warning]: Certificate file desktop-shjoton.crt is not matching the hostname DESKTOP-SHJOTON. Certificate generation is required.
[Warning]: Your Icinga Agent API feature has been disabled. Please provide either your ca.crt or connect to a parent node for certificate requests. You can run “Install-IcingaAgentCertificates” with your configuration to properly create the host certificate and a valid certificate request. After this you can enable the API feature by using “Enable-IcingaAgentFeature api” and restart the Icinga Agent service “Restart-IcingaService icinga2”

Input (Default 0 and c):

Could you please provide more information, for starters what you are trying to achieve and what you did so far.

Also there is a formatting feature here, where “code like” text can be formated properly

I am trying to install ICINGA Server on Windows and struck on the step in the attached snap.

Just to very clear here, installing a Icinga2 Server (a controlling instance) is NOT supported on Windows and my not work at. Using Icinga2 as an agent (being controlled remote by a server) though is.

Since I cannot see in the screenshot what the input parameters where, which you chose for this installation I cannot say if there is a problem with, please kindly provide them.
Apart from that, if you did not enter a IP address manually here, there seems to be a bug, where the IP address resolution is somehow faulty.
But then again there is now way to really tell, until you can provide the parameters which you put into it.

Thanks for your response.

I have used the script from the below ICINGA Link for Windows, used the script below from the below link and followed the instructions on the screen.

https://icinga.com/docs/icinga-for-windows/latest/doc/110-Installation/01-Getting-Started/

[Net.ServicePointManager]::SecurityProtocol = ‘tls12, tls11’;
$ProgressPreference = ‘SilentlyContinue’;
[string]$ScriptFile = ‘C:\Users\Public\IcingaForWindows.ps1’;

Invoke-WebRequest -UseBasicParsing
-Uri ‘https://packages.icinga.com/IcingaForWindows/IcingaForWindows.ps1’ `
-OutFile $ScriptFile;

& $ScriptFile

Now I have installed ICINGA on UBUNTU and looks like the installation is complete, but I am sure how to bring the ICINGA WEB Client to login.

Please advise.