Certain windows service monitoring is not working (e.g dhcpserver)

Dear guys,

I’m using Icinga Agent on windows to monitor services with “invoke-Icingacheckservice” command .

The thing is this command can get the desired service info locally on the monitored server, but after adding it to icinga, it’s showing
“[UNKNOWN] Services: 1 Unknown 4 Ok [UNKNOWN] dhcpserver: Service not found (0) (All must be [OK])”

I confirmed the Icinga Agent is using “NT Authority\System” to run the icinga service and tested runnning the command with this account locally working fine(used “Set-IcingaServiceUser” to configure this).

Actually I tested adding some other service monitoring to icinga, they are all working fine, only this one throws error, I’m running out of idea how to fix it, could you pls help me out?

is the name correct? try “DHCP”

Best Regards

Yes, confirmed name correct it’s “dhcpserver”, “dhcp” is for dhcp client

what’s the output of “Get-Service” on that particular machine?

Yes, it’s showing right.

Attaching a screenshot I run “Invoke-icingacheckservice dhcpserver” with NT Authority\System on the monitored server, it’s showing all right

and we can see “Icinga 2” is running log on as “NT Authority\System”.

do you use the “icinga powershell service”? what is the used user for this?

Yes Sir, that was using the default “Network Service” account, which I do not find a cmdlet to change it.

But I tried to manually change it to NT Authority\System, then the whole mornitoring stopped working, changing it back won’t fix it, have to reinstall icinga agent to get it back online