Bug report: RHEL 8 Apache/PHP-FPM misconfiguration


While installing Icinga Web on RHEL 8 using Apache httpd as my web server with PHP-FPM as recommended in the installation documentation, I encountered a problem. By default, the PHP-FPM installed as a dependency on RHEL 8 from the stock repos by running dnf install icingaweb2 icingacli listens on a Unix domain socket at/run/php-fpm/www.sock, whereas the supplied Apache configuration expects it to be listening on localhost:9000; see line 54 of /etc/httpd/conf.d/icingaweb2.conf, which reads:

SetHandler “proxy:fcgi://”

To work out of the box, it should be:

SetHandler “proxy:unix:/run/php-fpm/www.sock|fcgi://localhost/”

Alternately, I suppose an alternate PHP-FPM configuration could be supplied, but I didn’t research that option; anyway using the default Unix-domain socket is likely to be more performant, though I haven’t measured it at all. Thanks and please let me know if I need to follow this up or file this report elsewhere.

Hi, thanks for the report! Please open an issue in our issue tracker for packages.icinga.com: https://github.com/icinga/icinga-packaging/issues