Assign service sets

I’m not sure if I do something wrong but I’ve created a few service templates with different checks (for instance Invoke-IcingaCheckUsedPartitionSpace and Invoke-IcingaCheckCPU) and have added them to a Service set named “windows-service-base”. The set has the “Assign where” set to “host.template = windows” which my servers are using. If I go to the Hosts tab in the Service sets I see all my servers that should get this checks listed fine. But if I then go to the Overview - Services tab, I don’t see any services on any host. Also if I go into a host object and look under Services there is nothing listed.
Am I using Service sets the wrong way?

host.templates is of type array. Hence you need to modify your assign rule to:

“windows” in host.templates

Thanks Rolands… but that actually made it worse… if I do that the Hosts tab on the Serviceset gets empty? :frowning:

I solved this another way. I saw a “Services tab” on the Host Template and added the ServiceSet there instead and voila, it worked right away.