Any URL with /monitoring/ seems to error

I started with a fresh install of Icinga2 last month on a Ubunut 20.04 LTS (Azure didn’t have 22.04 yet). Ran the setup wizard per the documentation.

$ dpkg --list | grep icinga
ii  icinga-l10n                              1.2.0-1.focal                                                        amd64        l10n (short for Localization) provides all translations available for Icinga.
ii  icinga-php-common                        1.0.0-1.focal                                                        all          Icinga PHP Common for Icinga Web 2
ii  icinga-php-library                       0.9.1-1.focal                                                        amd64        Icinga PHP Library for Icinga Web 2
ii  icinga-php-thirdparty                    0.11.0-1.focal                                                       amd64        Icinga PHP Thirdparty for Icinga Web 2
ii  icinga2                                  2.13.5-1.focal                                                       amd64        host and network monitoring system
ii  icinga2-bin                              2.13.5-1.focal                                                       amd64        host and network monitoring system - daemon
ii  icinga2-common                           2.13.5-1.focal                                                       all          host and network monitoring system - common files
ii  icinga2-doc                              2.13.5-1.focal                                                       all          host and network monitoring system - documentation
ii  icingacli                                2.11.1-1.focal                                                       all          simple CLI tool for Icingaweb2 and its modules
ii  icingadb                                 1.0.0-1.focal                                                        amd64        database connector for Icinga 2
ii  icingadb-redis                           7.0.2-1.focal                                                        all          Persistent key-value database with network interface (metapackage)
ii  icingadb-redis-server                    7.0.2-1.focal                                                        amd64        Persistent key-value database with network interface
ii  icingadb-redis-tools                     7.0.2-1.focal                                                        amd64        Persistent key-value database with network interface (client)
ii  icingadb-web                             1.0.0-1.focal                                                        all          Icinga DB Web for Icinga Web 2
ii  icingaweb2                               2.11.1-1.focal                                                       all          simple and responsive web interface for Icinga
ii  icingaweb2-common                        2.11.1-1.focal                                                       all          simple and responsive web interface for Icinga - common files
ii  icingaweb2-module-doc                    2.11.1-1.focal                                                       all          simple and responsive web interface for Icinga - documentation module
ii  php-icinga                               2.11.1-1.focal                                                       all          PHP library to communicate with and use Icinga

Using MariaDB 10.3.34 on the same host.

I see lots of references to /monitoring/… such as:
https://icinga.com/docs/icinga-web/latest/modules/monitoring/doc/11-Add-Columns-List-Views/

If I try the url
https://MY_HOSTNAME/monitoring/list/hosts?addColumns=host_address

I get the error message:
Page not found. Enabling the “monitoring” module might help!

When I ran the wizard, it had me set up IcingaDB instead of Monitoring.

Looking through the code >>>>

/usr/share/icingaweb2/modules/icingadb/library/Icingadb/Compat/UrlMigrator.php

it looks like it’s supposed to catch those /monitoring/ links.

From what I’ve read, you don’t need the monitoring module enabled if icingadb is enabled.

How do I enable the compatibility mode, or whatever activates that UrlMigrator class?

Thanks!

Don’t complicate things too much :joy:

Maybe take a look at the proper documentation?

By enabling the monitoring module. But if you didn’t use Icinga before or if you don’t have the IDO backend still enabled, this will be of no use.

Thanks Johannes.

I missed that nugget of documentation and it helped a little.
Now I know that “addColumns” became “columns”

I certainly know how to RTFM, however the documentation is vast and it’s easy to get lost as you jump from component to component. Hence why I was grep’ing through source to find a clue.