All of a sudden two of my Icinga agents unable to connect to Icinga Master

Two of my agents stopped connecting to Master. As far as I know nothing is changed on linux box and port 5665 is still open

Here is the error I get

Remote Icinga instance ‘xxx’ is not connected to ‘xxx’

I listed icinga 2 version on my agent
icinga2 - The Icinga 2 network monitoring daemon (version: v2.10.5-895-g7c10b9a)

I tried to remove and setup everything again but still no success.

How can I fix this?


Any hints in icinga2.log on the agent? Which Version is installed at the parent?

BTW: You’re using a snapshot package which is for testing purpose only as mentioned here.

Hi Roland,
Here is our icinga version on parent side
icinga2 - The Icinga 2 network monitoring daemon (version: r2.10.5-1)

I got the image iof Icinga 2 from Docker Hub

What would be the right solution. I’m planning to fix this server and install another one in other location to monitor different agents and also monitor our current Icinga Parent .


Version on a parent needs to be equal or higher as described here.

Thanks Roland,
Do you recommend to downgrade the agent one or upgrade Master to higher version?

How easy would be the upgrade to the latest version? can you share with me your thoughts or any helpful link. I tried to downgrade the agent and didn’t have any luck on installing icinga2 on centos 7.


I prefer to have the latest version installed (since there are often bug fixes). Upgrading is most of the time just let your package manager do its job. And it is highly recommended to read upgrading docs before.