Acknowledgements not syncing between masters

Also thanks from my side @Al2Klimov.

In our setup we have both masters configured with

accept_config = true
accept_commands = true

every master has it’s own db.
But here it also happens also sometimes.

Is IDO HA explicitly disabled?

Does either the documentation or one of us devs say so?

yes it is set to false on both nodes

Actually I haven’t checked that in some time.
Also not sure why this is stuck in my head.
Maybe from this line in the log, I don’t know.
information/ApiListener: Ignoring config update from endpoint 'ma01' for zone 'azure' because we have an authoritative version of the zone's config.

Then I will from now on put this in the features-enabled/api.conf of clusters as well :slight_smile:
Thanks for the heads up.

Here is a semi-related issue where this was recommended by a former Icinga team member.


That workaround shouldn’t be needed anymore as the bug has been fixed.

Do you know when (version/commit) it was fixed? I had that issue in 2.11.2.

Have you tried v2.11.8?

I have not. Getting ready to go to 2.12.3 shortly, though.

Things not syncing properly since 2.12.2 in a HA setup sound suspiciously like it could be related to the following bug that was introduced there and is fixed in the already released 2.12.3: If this is the case, you should be able to find a log message similar to the one in the issue.