Acknowledge via icingaweb2 not working


Been running Icinga2 for a few years now, and love it - so firstly thanks for a great piece of software!

For quite a while now I have been unable to acknowledge warnings via the icingaweb2 UI. I found this bug which looks very similar to what I am seeing, but it says that was resolved in v2.4.2.

I am currently running v2.6.2 of icingaweb2. And the icinga2 daemon version is;

icinga2 - The Icinga 2 network monitoring daemon (version: r2.10.2-1)

Copyright (c) 2012-2018 Icinga Development Team (
License GPLv2+: GNU GPL version 2 or later <>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

System information:
  Platform: Debian GNU/Linux
  Platform version: 8 (jessie)
  Kernel: Linux
  Kernel version: 4.15.18-11-pve
  Architecture: x86_64

Hi Ben,

do you have icinga2 clustered and added both masters as an api connection endpoint in icingaweb2?
Did you try to enable debug log and see the acknowledge?
Please post your commandtransports.ini and your api user configuration for icingaweb2 user (api-users.conf),


Hi Carsten,

I am not running clustered, I just have a couple of LXC containers on my Proxmox host, one running the daemon (mon01) and the other running icingaweb2 (web01).


transport = "remote"
host = "mon01"
port = "22"
user = "mon"
path = "/var/run/icinga2/cmd/icinga2.cmd"

I can’t find any *api-user.conf" on web01, only on mon01 (where the daemon runs) and that contains a couple of entries only;

object ApiUser "mqttwarn" {
  password = "secret"
  permissions = [ "actions/process-check-result" ]

object ApiUser "openhab" {
  password = "secret"
  permissions = [ "actions/schedule-downtime" ]

Do I need something in there to allow icingaweb2 access to the API?


Hi Ben,

you should start using the API as command transport, see the docs for more information how to enable it. I think the external commnad reader feature will be dropped soon.

Best regards,

Thank you so much for pointing that out - I have switched over to using the API command transport and now it appears to be working again.

Thanks again for the very prompt response!

1 Like

Your welcome :slight_smile: please mark the topic as solved, so others can see that there is a solution for the problem.

1 Like

Just one more thing to add: @anon66228339 is right about the commandpipe feature being deprecated in the future. But it always had one drawback that might have hit you: You always had to run Icinga Web 2 on the same host as the Icinga 2 instance you wanted to communicate with. That’s history when using the API.

1 Like

Thanks Thomas. Appreciate the feedback.