Access icingaweb via citrix content switching


I have one working icinga server. I need to give access to external company by using Citrix Content Switching feature. When i set up the policy to access icingaweb, they citrix policy expression i used is:
So it works and i could access the Login page:
However, after I put in my credentials, it let me log in for 1 second and right away log me out (I could quickly see the screen after logging in).
In the http log, i could find this:
“GET /icingaweb2/dashboard?renderLayout HTTP/1.1” 403 - “” “Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0”

Do you have any idea what is wrong?


maybe its the cookie that is set to another path/domain. You can test it (but you have to delete all cookies then) by setting cookie path in /etc/icingaweb2/config.ini to

path = "/"


Hi Carsten,

Thank you for your answer here. May be I don’t get it. I tried to set cookie in config.ini as you suggested for the test and the same sympton when i tried to access internally or externally. It means log in and being signed out right away.
I removed the cookie setting and it startes working both internally and externally now. How could this help, could you please explain?