New r2.12.3-1 not compatible with r2.11.2-1?

Hi Antony,

Yes, Master - Agents setup.
Think you are righ, my Agent is newer than the first master.

Btw, found a good explanation about upgrading/downgrading specific version: LINK

Will try to update the master, hope it doesnt mess up my master when upgrading using apt-get. Any experience upgrading?