Icinga2 can't execute hostcheck on Windows: execvpe(/usr/lib/nagios/plugins/check_disk.exe) failed: No such file or directory

I cannot interpret much from the long thread w/o summary, but this initial request is what I’d check on.

Cluster-zone -> satellite
Agent -> yes

Cheers,
Michael

I have run in the same issue as @ibex
I have a simple setup: single master server and I have a remote windows machine with the agent installed. The windows machine cannot be reached from outside, so the agent is connecting to the master and receving the top down scheduled checks to run.
Everything configured via director.
Service checks are being executed fine with the windows agent.
I cannot get the host check to be executed by the windows agent itself:
image
I assume that the “command_endpoint” needs to be set so that the command gets executed by the agent itself (e.g. as it gets set for service to “command_endpoint = host_name” if the option “run on agent” is set to Yes).
But would that really meant that I have configure per host (=agent) a zone so that I can select it as “cluster zone”? Or did I miss an option in director?

Thanks.

Hi @kosli thank you for joining,

As this is a very old topic please start your own and link to this one.
Dont forget to post some of your own configuration that you have in the setup.

Dont forget to read the community guidelines :slight_smile:
Thanks,

Thanks @belastingvormulier
I have created a new thread at Not able to execute hostcheck on the host itself