Version 2.10.x and requirements

I have seen that version 2.10.x has been released.
Since I wanted to test the update in my Ansible role, I went through the documentation and came across the requirements.
These are - for me - not conclusive.

PHP version >= 7.2
Icinga PHP Library (ipl) (>= 0.9)
Icinga PHP Thirdparty (>= 0.11)

  • PHP8.1 is still not supported. (There is an open issue for this, which exactly describes my problem.)
  • Icinga PHP Library is only available in version 0.8.0.
  • Icinga PHP Thirdparty only in version 0.10.0

This means that the requirements cannot be fulfilled at all.

Either you release this fix or you change the documentation. :slight_smile:

Regards, Bodo

1 Like

The documentation shown by default is latest (master) which supports indeed PHP 8.1.

The documentation for v2.10 is here

Huh, never gave thought to that tbh. But this seems to be an easy avoidable source of confusion.
I always thought latest is the last released version, not the git master.

Imo the links on the Docs page
should then link to the latest released version, not the master.

Might be a dumb question, but how would I find this link Icinga Web 2 v2.10 or any of the version specific documentations, if not by manually editing the URL?

@bsheqa I told you so, I believe. :sweat_smile:

Through the about page in Icinga Web 2. Since v2.10 at least :sweat_smile:

You are absolutely right and I fixed that!

1 Like

Right, the master branch, but not the latestet Release!

I know

It got reset over night. Should be fine now again.

I like to build a molecule test that installs the latest icingaweb2 release against a PHP8.