Remote check not working

Last year I had setup a Icinga2 Server to Monitor several Hosts and i works fine.
Now I have setup a new one in a different area and the remote check not working.

The diffent is that in the “old " one al my configuration are under /etc/icinga2/zones.d/master/…
And I have also in my Hostfiles the “object Endpoint” and object Zone” configured.

On my new Installation, all configs are now under /etc/icinga2/conf.d/… and in my Hostfiles are no “object Endpoints” and object Zone" confugured.

On my new Installation all my “remote checks” like disk or procs looks like to check the Icinga Master itself.
So it is necessary to create Endpoints and Zones? I have a small setup so I don`t need this, or?

Would be great if someone can help on this issue :pray:

Here are my Hostfile:

object Host "host1" {
  import "generic-host"
  display_name          = "Test Host"
  address               = ""
  vars.os               = "Linux"            = "dmz"
  vars.service_squid    = "1"

  vars.disks["disk"] = {
 /* No parameters. */

 vars.load["load"] = {
 load_wload1  = 15
 load_wload5  = 10
 load_wload15 = 5
 load_cload1  = 30
 load_cload5  = 25
 load_cload15 = 20

 vars.notification["mail"] = {
 groups = [ "webadmins" ]

Here are my Servicefile


apply Service for (load => config in host.vars.load) {
  import "generic-service"
  check_command = "load"
  vars += config

apply Service for (disk => config in host.vars.disks) {
  import "generic-service"
  check_command = "disk"
  command_endpoint = host.vars.address
  vars += config

// Check Squid Proc is running
apply Service "Squid" {
 check_command = "procs"
 vars.procs_command = "squid3"
 vars.procs_critical = "0:2"
 vars.procs_warning = "1:1"

assign where host.vars.service_squid == "1"

For running any check plugin on a target host you could configure distributed monitoring (in that case you need zone and endpoint objects for every single host) or run them via by_ssh.

1 Like

Hello @joltmann :slight_smile:
Did Rolands answer help you out with your issue?

Would love to hear back from you whether it worked or not :slight_smile:
Have a nice day,

Hi Feu,
sorry for my late answer. Yes Rolands answer was a good hint.
I works now :slight_smile:

1 Like