Notification not sent to anybody

Hey there,
I have an issue which I cannot really understand. I created a user template with all state types and transition types. Then I created a notification template and apply rule. But on service or host state changes I see the message “For this problem was no notification sent”. I see the Contactgroup and Contact in the Host and Service Overview. Does anyone have an idea where I can search for a solution?

Best regards
Stephan

Hey @swild2,
I have/had the same issue. About 2/3 of all notification log entrys were such ones.
I “fix” that issue by setting up a scheduled task deleting them once a day. This improved the database performance, but it will not reduce the notification count leading to some misinterpretations.

So I’m also interested in a proper solution for that

Kind regards
Sebastian

Hey @nexo1960 ,
I think you misunderstood or I explained it in a bad way. I only receive Notifications as “Custom Notifications”.
Here is my config built in icinga Director:

object User "myUser" {
    display_name = "My User"
    email = "MyUser@Domain.TLD"
    enable_notifications = true
    period = "24x7"
    states = [ Critical, Down, OK, Unknown, Up, Warning ]
    types = [ Acknowledgement, Custom, Problem, Recovery ]
    groups = [ "all_notifications" ]
}


template Notification "mail-host-notification-tpl" {
    times.begin = 0s
    times.end = 0s
    command = "mail-host-perfdata"
    interval = 0s
    period = "24x7"
    states = [ Down, Up ]
    types = [ Acknowledgement, Custom, Problem, Recovery ]
}


template Notification "mail-service-notification-tpl" {
    times.begin = 0s
    times.end = 0s
    command = "mail-service-perfdata"
    interval = 0s
    period = "24x7"
    states = [ Critical, OK, Unknown, Warning ]
    types = [ Acknowledgement, Custom, Problem, Recovery ]
}


apply Notification "mail-host-all-notifications" to Host {
    times.begin = 0s
    times.end = 0s
    command = "mail-host-perfdata"
    interval = 0s
    period = "24x7"
    assign where host.enable_notifications
    states = [ Down, Up ]
    types = [ Acknowledgement, Custom, Problem, Recovery ]
    user_groups = [ "all_notifications" ]
}


apply Notification "mail-service-all-notifications" to Service {
    times.begin = 0s
    times.end = 0s
    command = "mail-service-perfdata"
    interval = 0s
    period = "24x7"
    assign where service.enable_notifications
    states = [ Critical, OK, Unknown, Warning ]
    types = [ Acknowledgement, Custom, Problem, Recovery ]
    user_groups = [ "all_notifications" ]
}

Is there a configuration mistake?

times.begin= 0s

This is the default and therefore it is not needed to add it to the configuration

times.end = 0s

This means that icinga should stop after 0s and therefore no message will be send

interval = 0s

I think this will disabled any type of re-notification - is that what you really want?

Hi,
Yes there should only be 1 single notification. So the interval is correct. But the times.end was my Problem. The range was too short. I changed the value to 5m and the notification is working. Thanks a lot.