No host, no service after running Node Wizard

I just finished installing icinga2 on my linux, and i was login in. it succesfully, i see services running. I just want to monitoring snmp using icinga but i dont how to do, i read a view article and i want to add host first using node wizard after complete i was restarting icinga. and then there is no host or services on my dashboard. pls help me fix this. thx

  • Icinga Web 2 version 2.7.3

  • Used modules and their versions Monitoring Module 2.7.3

  • Web browser Firefox

  • Icinga 2 version used (icinga2 --version)

icinga2 - The Icinga 2 network monitoring daemon (version: r2.11.2-1)

Copyright (c) 2012-2021 Icinga GmbH (https://icinga.com/)
License GPLv2+: GNU GPL version 2 or later <http://gnu.org/licenses/gpl2.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

System information:
  Platform: Linux Mint
  Platform version: 20 (Ulyana)
  Kernel: Linux
  Kernel version: 5.4.0-74-generic
  Architecture: x86_64
  • PHP version used (php --version)
PHP 7.4.20 (cli) (built: Jun  4 2021 21:24:55) ( NTS )
Copyright (c) The PHP Group
Zend Engine v3.4.0, Copyright (c) Zend Technologies
with Zend OPcache v7.4.20, Copyright (c), by Zend Technologies

Hii @fndrsm, welcome to the community.

Please check whether this helps you.

1 Like

oh gosh, i just work around for this problem since 2 days ago. i revisited this article many times but i was understood the article that u give me. Before i was delete the icinga2.conf for uncomment and recomment the include_recursive conf.d & include conf.d/api-users.conf too.

Here what i did that make the hosts and services back.

  • Delete the icinga2.conf on etc/icinga2/icinga2.conf

  • Copy icinga2.conf.orig then paste it, then it become to icinga2.conf(copy).orig

  • Rename icinga2.conf(copy).orig to icinga2.conf

  • Then run icinga2 node wizard, and don’t forget to type n for
    Do you want to disable the inclusion of the conf.d directory [Y/n]:

Many thanks @yhabteab for helping me realize the step.